Unable to repair disk with Disk Utility

N/A

Registered
Hello.

I was doing a Disk Utility verification of my startup HD.
These are the problems it found:
Problem: Volume Bit Map needs minor repair, 4, 180
Problem: Volume Bit Map needs minor repair, 4, 300
Problem: Volume Bit Map needs minor repair, 4, 418

But the Repair button is disabled! And I have locked up the program with admin password by clicking the lock in the lower left section of the window.
Isn't it possible at all to repair startup disks (I believe it was possible in OS 9) or hasn't the Repair function been implemented yet in OS X Disk Utility?

N/A
 

marmoset

Official Volunteer
You could always restart the machine, holding down the "S" key while you do. The machine will then boot into whats called "single-user" mode. Once it's booted, you'll be at the command prompt. Type "/sbin/fsck -y" and watch the messages it outputs. Run fsck multiple times until it reports no errors. Then type "exit" to boot into regular multiuser mode.
 

VGZ

Registered
Boot into 9 and put the X install cd in. The Disk Utility application is on the disk and can make the repair when you are booted into 9.

Hope this helps :),
 

N/A

Registered
I restarted and held down the S key.
What a DOS experience! :D
Anyway, I wrote in "/sbin/fsck -y" (and noticed that keyboard layouts didn't work in the more primitive command environment...) and hit enter.
The test ran and it found a minor error in the volume header. The numbers within the parantheses that appears after the error message was (1, 0).
The problem was repaired and then I ran the test once again.
This time a minor error was found (not in the volume header this time). The numbers were (4, 418). The error was repaired and I ran the test for the third time. Now I got the same error as I got first; the volume header error @ (1, 0). The fourth time I ran the test the minor error @ (4, 418) was found and repaired. And that way, my friends, it kept going on and on again.
When I had repaired those two errors a few times, I got tired and rebooted into OS X.
This time when I ran the Disk Utility verification, I only got one error instead of the three I got earlier (see my first msg). This error was the one about the volume header (1, 0).
I can't boot into OS 9 I'm afraid :(
Both when I try to start Classic and when I choose OS 9 as startup system and reboot, I get the same results: it just stops and does nothing when it comes to the gray screen with a happy Mac on it. It doesn't even get to the extension loading. I have thrown away the old system 9 and installed a new copy but still the same results. I think I will have to reformat the drive to be able to run OS 9 again :(

N/A
 
Top