Uninstall DUAL BOOT... PLZ HELP

Gnarled

Registered
X(public beta) was working for me untill i installed a currupted update(4k56) after that, it wouldnt boot, so i went back into os9.1 and deleted all the VISIBLE files created by OSX, then i reinstalled OSX, it installed fine and will boot, the only problem is that it didnt runt the setup program so i couldnt set up the passwords, so now when i go boot into OSX i get a login screen but cant login (no, my old passwords dont work)

then i tried booting into single user mode(terminal, do this by holding s upon reboot) and i played around in the terminal and it did let me su as root, but i couldnt change the password because when i tryped passwd, it gave me some error about netinfo not existing. i also tried addusr and some other stuff.

WHAT DO I DO
Is there a way i can login to X? this would be good!

Is there a way i can FUL:LY UNINSTALL X without reformatting? does it involve deleting hidden files?(i do know which hidden files were created by X cause i checked the list of hidden files against a computer that didnt have X installed.)

IS there a way i can just run the setup Program again??

HELP!!!
 

zaustin

Member
check darwinfo on ways to edit NetInfo configuration files from the terminal. Then you add your root/main user password into NetInfo and you should then be able to log in.
HTH.
 

mtc7501

Message Board God
Here's your problem, you deleted only the VISIBLE files. I have had this problem many times. The answerfor me was to go in and change all the invisible files to visible and then delete, or just erase the disk that X is on. I learned my lesson. I now have partitioned drives just because of this. It is a pain to have to delete all those invisible files without erasing the whole disk.
 

theed

Registered
A note on NetIfo - it only launches in multi-User mode, so if you launch single user, the OS looks at password files and such like linux or other unices. You can edit these files, but it will have no effect once you reboot normally, because then netinfo's in charge

conversely, I have no reasonable answer as to how you can edit netinfo stuff while booted into single user. Additionally, adduser means nothing, for as soon as you get the machine running normally, the files that adduser would play with would have no authority.

The only suggestion I could give is 1: reinstall after wiping the invisible files or
2: beat on niutil at the command line. my coworker is working on making some adduser scripts that would be a linux type CLI front end for niutil - if anyone else feels like being backwards like that. :) They're not ready yet. We both have other things to do.
 

Gnarled

Registered
IS OS9 dependent on any invis files, or can i delete them all, it makes me nervous messing around with invis files, cause, after all, they are invis for a reason.

Do u know which invis files i might want to delet specifically.

Also, what is a good app to view invis files, i know ResEdit works, but if i use it, i cant delete invisible folders i can only delete their contens.
 

jove

Member
Hello,

OS 9 does not depend on any invisible files. I have purged, rebuilt, split, and united too many MacOS9 installs :-> I never had to deal with invisible files.

From Resedit you can get file or folder info and then make the folder visible. Once that is done just drag it into the trash from the finder.

Jove
 

Gnarled

Registered
heres something that i did not expect to happen. I was playing Rogue Spear one night and it crashed, which is usual;) Then when i rebooted it couldnt boot it just gave me the system foler ? screeen. It couldn't mount my HD, so i had to reformat, while i was at it, i partitoned my disk, so now i got OSX 4k60 installed the right way.
 

VGZ

Registered
Originally posted by Gnarled
Also, what is a good app to view invis files, i know ResEdit works, but if i use it, i cant delete invisible folders i can only delete their contens.
You can use Sherlock to search for invisble files and do 
command-del to to trash them. OS 9 uses invisble for the dektop folder and its database.

For anyone else that needs to delete OS X on a dual-boot single partition:
Search in Sherlock and delete all invisible files that are not in the OS 9 directory.
 
Top