Uninstalling OS X - ::sniff::

IslandJordan

Registered
Well, after loyally using the Beta and being the first person in Boston to own OS X (I got a tshirt for it, too!) I must uninstall. I love OSX to death... so these are my reasons:

- OS X runs ass-slow on my iBook SE 366.
- Classic has grown buggy and won't work very well anymore.
- I do lots of graphic work, and my Wacom Graphire is not yet supported.
- When booting on 0S9, I run into so many errors, I can't run 1/2 of the software I booted into 9 to run.

So, until I get my new iBook (when I earn enough money by selling my body for the rest of the summer), and when Macromedia releases a Carboned Dreamweaver and Wacom releases it's OSX driver, I must uninstall.

But now I'm stuck: What's the best way to go about this? I am tempted to back up what I can on zips and do a clean reinstal. Unless there is a way to completely uninstall OSX, leaving only 9 and having everything put back where it was before the X install.

Any suggestions?

Jordan
 

HashBrown

Registered
Try this applescript, Be careful though I have not thouroughly tested it. This will remove all OS X files.

property root_items : {"bin", "dev", "Network", "private", ¬
"sbin", "usr", "Volumes", ".DS_Store", ".hidden", "cores", ¬
"etc", "tmp", "var", "Applications", "Developer", ¬
"Library", "mach", "mach.sym", "mach_kernel", "System", ¬
".Trashes", "Users", ".vol"}
property systemfolder_items : {"Classic", "Classic Support", ¬
"Classic Support UI", "ProxyApp"}

tell application "Finder"
activate
try
set this_version to the version as string
if this_version does not start with "9" or ¬
this_version is not greater than or equal to "9.1" then ¬
error "This script requires a Mac OS 9.x system greater than 9.0.4."
display dialog "This script will move Mac OS X items from the startup disk to the trash." with icon 2
display dialog "Should this script delete the Users folder?" buttons {"Cancel", "Yes", "No"} default button 3
set the users_flag to the button returned of the result
repeat with i from 1 to the count of the root_items
set this_item to item i of the root_items
if this_item is not "Users" or ¬
the users_flag is "Yes" then
if exists (item this_item of the startup disk) then
delete item this_item of the startup disk
end if
end if
end repeat
repeat with i from 1 to the count of the systemfolder_items
set this_item to item i of the systemfolder_items
if exists (item this_item of the system folder) then
delete item this_item of the system folder
end if
end repeat
beep
display dialog "The Mac OS X items have been placed in the Trash."
on error error_message number error_number
if the error_number is not -128 then
beep
display dialog error_message buttons {"Cancel"} default button 1
end if
end try
end tell
 

Soapvox

Want some of my Kool-aid?
I am very sorry to hear that. I develop in ultradev and fireworks on a Bronze G3 laptop and while I admit it is painfully slow starting up and refreshing in classic, I find it so amazing what you can do with X. If you get a chance I hope you reconsider, one interesting since I switched to X, I have started relying less on wysisyg and do much more touching up in Pepper and BBedit ;) . I understand your frustration though and hope that everyone sends emails to macormedia and their favorite software developers to tell them we are anxiously awaiting X versions of their software (and point out that becuse it is unix, it will bring a whole new audience to them).
 

IslandJordan

Registered
I didn't mean I'm NEVER going to use OS X, I just think that for my purposes, I'll wait until it's at least a LITTLE more universal. Incidentally, I figured out a great way to get rid of OS X...

When booting in OS 9, I ran into a harem of errors, especially due to Quicktime. I was getting VERY frustrated because it was not loading Quicktime because it was expired, and the new installer would give me a different "unexpected error" every time I attempted to install an updated version.

Right then, my Software Update control panel told me that there was a bunch of 9.1 stuff that needed to be updated - including an iBook firmware update. I downloaded all the stuff, and when I attempted to restart and update the firmware, I got the ? at boot up. After using disk first aid and Techtool for 3 hours, I could not repair the fatal mount error on the hard disk. I reformatted. And (obviously) EVERYTHING is gone... the MP3s, the email addresses, the websites, the graphics, everything.

While I almost cried on the floor in the fetal position for not having the opportunity to back up anything before reformating, it feels nice to be starting from scratch. I've left my disks for Microsoft Office at school in Boston, and my copy of Dreamweaver is on a disk lisenced to my design class at school... so I'm screwed.

Just needed to vent, sorry kids.

Jordan
 
Top