Unreal Tournament Preview for OS X!!!


This is what I've been waiting for since March 24th. Nice to finally see something come outta Westlake Interactive. You can get it here:


I've already been having problems with it though. First I copied the Unreal Tournament OS X application file to the Unreal Tournament folder. Then, I tried running UT-X and it gave an "assertion failed" error when it tried to enter game mode (SoftwareRenderDevice.SoftDrv). Oh well, software rendering doesn't work. So then I deleted UnrealTournament.ini and relaunched UT-X so it would ask me what rendering device to use. Well, doesn't look like the mouse likes that dialogue. I wasn't able to click ANYTHING in the window (I WANT to click OpenGL), so I just hit enter and it loaded using software rendering again and quit with the same error. Then I tried manually telling it to use OpenGL by adding "OpenGLDrv.OpenGLRenderDevice" in all the appropriate fields under "Engine.Engine" in the .ini, and it got almost into the game, but quit with an error in Mac.OpenGL :(. I'm gonna try rebooting with only one monitor plugged in; who knows... it may solve my problem. If anyone's got any ideas though let me know. I can't wait to get this thing running.
Same bullshit with one monitor plugged in.

Here's the error I get when I run it using Software Rendering:


Here's what I get when I run using OpenGL the first time:


And any other time after that I just get this:

Dang Dude...hmmm

Ill grab it and try it, n report back if I get the same error...

have you had any dev builds on your os x install? that may be a thing to look out for...

Unreal Tournament for X crashes my system every time I run it. I have to do a cold reboot. Anyone have any suggestions? I'm running an iMac DV SE 400 MHZ, 256 MB RAM.

I have it installed on an iMac 350 and it is running fine now. I did get those dialog windows when I had moved the folder to another place on my systems, but then I re-ran the installer so I could tell it where my Unreal folder was everything worked fine (though I wouldn't mind having frame rates closer to how it runs in 9.2.1).

Hardware: iMac/350, 320MB/30GB
Software: Mac OS X 10.1, Unreal Tournament GOTY

I'll give it a try on a G4 tomorrow.
If you read the notes and known bugs before you downloaded it, it said that sfotware rendering was not supported at all, and that Rave and Glide will NEVER be supported... only openGL for now
To fix some of the bugs try updating to the latest version of OS X. If that doesn't work downgrade one OS lower.

Then try editing the .ini file to open only in OpenGL.

I had one crash while trying to run it, then I changed the .ini file and it works perfectly now.

Me = Happy. :)
Even with the .ini set to use OpenGLDrv.OpenGLRenderDevice, the game still quits on me right when the CityIntro animation is coming on.


And forcing it to start on Entry.unr instead of CityIntro.unr didn't help at all. I got it to run once somehow. I think what I did was duplicate my TacticalOps.ini and rename it UnrealTournament.ini, but I've tried it numerous times since then without any success. Really confusing me. You'd think that with a clean install of Unreal and the application in the right spot it should work fine. I can't even click the radio button to choose OpenGL. I can't imagine a simple detail like that not working. Maybe it just doesn't like me :p If anyone figures it out, let me know. Also, is there anywhere to get a more detailed reason of the error message (above). Console.app says"

Sep 30 21:32:04 localhost /Applications/Unreal Tournament/Unreal Tournament OS X: kCGErrorInvalidConnection : CGSReleaseWindow called with invalid window"

UnrealTournament.log doesn't write for some reason when it quits unexpectedly. Maybe I'll just reinstall it 4 or 5 more times. Maybe then it'll work.
Got it to load. But if I select any menu items it quits unexpectedly. Gimme another day and maybe I'll be able to open the Preferences menu-item. :D

Make sure audio is set to use OpenAL.OpenALAudioSubsystem. That was the key.

Back to trying again!
OSX Unreal Tournament starts up without a hitch on my G4.

Only problem is, it runs like treacle. I get around half the FPS I get when i run it under OS9, and the controls are somewhere south of unresponsive.

its nice to see that work is coming along on UT for X, and I'll be following the developments closely. But for now, its pretty much unplayable.