Urgent!! My Home Folder: I can't get into it!

Lt Major Burns

"Dicky" Charlteston-Burns
My home folder denies me. every time i even single click it, before it is even highlighted, i get a message saying that i don't have sufficient priveleges. it's my home folder, and i'm the admin. i restarted, did a permissions fix (which found a few things) but won't let me in to the home folder still and now it has reset the desktop and all my settings. i am very scared about losing my documents, as these weren't backed up (i lost the back up).

when i get info for the Home folder, it says i have "no" access. owner is system. if i try and change the owner to "tom" or whatever, it switches back to system just as soon as a have clicked it. please help.
 

bobw

The Late: SuperMacMod
Have you changed the user name anywhere?
 

Lt Major Burns

"Dicky" Charlteston-Burns
no. what i can think of was that i was setting up a "family" account. from that account i tried to access my (main) home folder, but that i needed permission (which i expected). i never got in to it, and i tried changing permissions in the "get info", but i remember not getting very far. nothing was changed, i don't think. i was switching around the different users quite a lot that day, it was only afterwards, when i fully logged out and back in again, i think, that the serious changes took effect. this was a week ago, and the computers been lying dormant since then, i only booted it up today to find the problem. how can i get it to promt me for my admins password?
 

adambyte

Registered
btw, if you're just worried about finding and saving the data, in general... (This requires two firewire-capable Macs). Start up your data-filled Mac in FireWire Target disk mode by holding down the T key at startup. Then plug it in via FireWire to another Mac. It will appear as an external hard drive. Then copy what you want. ( you might have to "Get info" on the target disk and choose "ignore priviledges" to get your stuff to copy ).

Hope this helps
 

Lt Major Burns

"Dicky" Charlteston-Burns
thank you, root user is the way to go, but it asks me to enter the old password first. i have no idea what the old password is. is there a known default?
 

bobw

The Late: SuperMacMod
You must have turned Root on previously. The first time it should ask you for a password to use. Try your Admin password.
 

Lt Major Burns

"Dicky" Charlteston-Burns
no, it does work. i'm in, and i've recovered everything. except in the deletion process mentioned earlier, it deleted my entire iphoto folder. without using trash. 4,000 images, some backed up, the best ones i suspect weren't. i'm now going to spend the next however-long looking to find any backups i may have made.

and also buying a 250gb firwire drive. any reccomendations?
 

Lt Major Burns

"Dicky" Charlteston-Burns
damn damn

damn damn

damn damn

damn damn

no back-ups anywhere. just bought a western digital internal 250gb SATA. gonna get cloned to every week. it's such a strange feeling losing all those photos. with the music, it was always possible to get them back. there is no hope of getting these back.
 

thewelshman

Registered
Sounds like you didn't set your account to administer the machine, if that were done you can set the permissions on a folder from the "Get Info".

Do you have an accout that can administer the machine?
 

Lt Major Burns

"Dicky" Charlteston-Burns
i'm admin. it went wrong... root superuser sorted it. it;s fine now. i'm just completely distraught about the loss of images, which was entirely my fault. although i now know there is a backup for most of it. i just can't find the bastard dvd. i know i had it somewhere....
 

thewelshman

Registered
I use root account as well, but we get frowned upon for doing it.

Have you lost images or a folder from your disk? I have tried DataRescue, Norton and so on. However if you deleted files rather than files lost due to some problem on the disk, then things are more difficult to retrieve.
 

TommyWillB

Registered
Lt Major Burns said:
no. what i can think of was that i was setting up a "family" account. from that account i tried to access my (main) home folde...
I think you just identified your own problem.

If you create a LtBurns user, and put all your stuff there... You will not be able to access that LtBurns "home" with your new "family" account because that's effectively a differnt user.

Log back in as LtBurns, and voila you'll have full access to that folder and data.

For information on sharing between users, do a search on this forum. You'll find multiple threads on the topic.
 

Lt Major Burns

"Dicky" Charlteston-Burns
ha ha yeah i realise now. if only macos had windows system restore. almost guaranteed get-out-of-jail-free card, that one.

from now on, i'll be cloning my working HDDs to a huge backup disk on a weekly basis assuming everything works.
 

thewelshman

Registered
Actually what you should do, from an admin point of view is to keep the OS on a smallish root disk and keep all "Users" home directories and "Applications" etc on their own disks (they are cheap). In reality there is a large hit reading and writting swap, temp files, actuall files to the same disk. This prevents the root disk for grinding to a halt as a results of being stuffed.

What I did was to buy two 10GB root disks (cloned every week or so, but could be mirrored via the OS), then have large disks for VIDEO and AUDIO, there are enough interface in a Mac to sink a battleship, if you run out its cheap to either buy a SCSI interface or SATA.

At some point a single disk system will run into space problem, then you'l have to do what I've just said.

Note:
If you remove a user from a MacOSX system using the OS to do the job, that user's home directory is backed up and compressed. However if none of the above separation has taken place you'l be stuck with a ginormous directory to restore, note that there is a way out of this was well, you can extract specific material from the PAX file.
 
Top