USB Flash Disk Problems


Afternoon, can anyone shed some light on this?

I got given (yes a freebie) a flash disk (128Mb) of unknown brand.

It worked fine on my mac for about a month and also on my work windows machine.

Now everytime i use it, my mac only recognises it as read only. It wont let me format it or anything! The windoes machines can see it and write to it fine.

Ive tried formatting it on the windows box as FAT32 and NTFS and that didnt work, the mac STILL saw it as read only.

Any ideas on what i can try? I just want to remove this silly write protection. I actually want to use this device.

(yeah i know i can go and buy one for £30 or something, but im broke at the moment...and cheap :p)
The most obvious would be a small write-protect switch, as seen on many USB Flash Disk. But I guess you already checked that :)
Yup, cant see or find a switch of any sort :S
That would also not really explain why windows can write and mac cant would it?
Try formatting it in Fat16, or I think windows xp just calls it fat. That is what they usually ship as. It makes sense that the Mac can only read NTFS, because there isn't NTFS read support yet, IDK why FAT32 doesn't work.
UPDATE: my fedora core 2 box can read and write to it too. will have to try formatting it into some unix partition.

Confused now.
Take a look in DiskTool under the Partion Tab, you should find a "Locked" checkbox there.
(I'm running a swedish system so I'm not sure exactly how everything is named in English)
Thanks for the help. That didnt work. Neither did formatting it into every conceivable file system :) guess my mac wont be able to write to it.