Users Losing Connection to 10.2.8 Server

trentwac

Registered
I am runnign an 10.2.8 server on g4 dual 867 1.75gb ram, with os9.2.x and 10.2.x-10.3.x, pc xp,2000, 2003users.
mac users are hanging up intermittently, sometimes 3-4 times a day, or maybe not for a couple of weeks at a time. pc users don't have any problems at all. i assume that this is a afp problem, but don't know how or if there is a fix for it.

the watchdog event log is.

2005-06-17 10:06:40 cdt terminating due to signal.
2005-06-17 10:06:40 cdt automatic reboot timer disabled.
2005-06-17 10:06:40 cdt reaped child process 351 ("/usr/sbin/sambadmind"); quit due to signal 15.
2005-06-17 10:06:40 cdt reaped child process 355 ("/usr/sbin/macintoshmanagementserver"); quit due to signal 15.
2005-06-17 10:06:44 cdt waiting for killed child (pid 352)
2005-06-17 10:06:44 cdt reaped child process 352 ("/usr/sbin/printservicemonitor"); quit due to signal 9.
2005-06-17 10:06:44 cdt waiting for killed child (pid 354)
2005-06-17 10:06:44 cdt reaped child process 354 ("/usr/sbin/serversettingsd"); quit due to signal 9.
#end-date: 2005-06-17 10:06:44 cdt
#start-date: 2005-06-17 10:07:47 cdt
#fields: date time s-comment
2005-06-17 10:07:47 cdt started child "/usr/sbin/sambadmind" as pid 344.
2005-06-17 10:07:47 cdt started child "/usr/sbin/printservicemonitor" as pid 345.
2005-06-17 10:07:47 cdt started child "/usr/sbin/hwmond" as pid 346.
2005-06-17 10:07:47 cdt started child "/usr/sbin/serversettingsd" as pid 347.
2005-06-17 10:07:47 cdt started child "/usr/sbin/macintoshmanagementserver" as pid 348.
2005-06-17 10:07:47 cdt automatic reboot timer enabled.
2005-06-17 10:07:48 cdt reaped child process 346 ("/usr/sbin/hwmond"); quit with exit status 1.
2005-06-17 10:07:48 cdt process "/usr/sbin/hwmond" respawning too rapidly!

will installing either the 10.3.x or 10.4.x server update correct this?

i have looked on apples site and it appears that they know about it, but no answers yet.

 

fenderman

Registered
Hi there. We have a similar problem, although we have OSX clients connecting to an OS9 server. The clients lose their server mount every day, sometimes several times a day. It's a drag. Our local Mac dealer has taken this up Apple who say they no longer support OS9. I have started to monitor this in Console Log and this is what we are getting;

AFP_VFS afpfs User Command: sosend failed for request 32
AFP_VFS afpfs_Reconnect started /Volumes/Accounts Server
AFP_VFS afpfs_Reconnect: Wrong version 4 or no more attempts 0
AFP_VFS afpfs_unmount: /Volumes/Accounts Server, flags 524288, pid 2876
AFP_VFS afpfs_unmount: succeeded

I know this log entry doesn't look anything like your but thought that someone may know what's going on. Our log suggests that it's an AFP problem. We're working on it and I'll post another reply if I get anywhere.
 

trentwac

Registered
I tried something last week that seems to be working. I turned off Appletalk, and am making all of my users connect via TCP/IP only. So far it has run days without any issues. I'll keep the thread posted if this continues to work.
 

Billandrews

Registered
It sounds like you have the Spanning tree protocol running on your network switch. If your switch is not programable, then you have a problem. Appletalk and Spanning tree do not run well together. The only fix is to shut one of them off. If you can't shut off Spanning tree on your switch, then you have to shut off Appletalk on your Mac. Apple is aware of this problem and there is no fix planned.
 

trentwac

Registered
I will check out the network switches and see, but I know the default configuration is spanning tree off, and as far as I know noone here would have turned that on.

Thanks for the info.
 

joeboe

Registered
We are having the same problems with a 10.3.9 server, so I doubt an upgrade will fix it. I'm curious about this as well.

We have spanning tree turned off, but another subnet in our network has it on. There are a few mac clients out there connecting to us. Could this be our problem?
 

trentwac

Registered
I know this has been hanging out there for quite a while, but I have noticed that the freezes seem to come when a pdf file made on a PC is opened up on one of my Macs.

That seems to be the only thing that I consistently see happening when the server hangs.

None of my PC users hang up only the Mac users.
 

fenderman

Registered
I know this thread has been open for a long time now, but we've had this type of problem on and off for years and I believe we recently solved it. We have OSX clients connecting to an OS9 server, and the clients were getting disconnected constantly.

I suspected a timeout issue or network protocol problem, but I had read about other users with similar issues who supsected the Energy Saver in the Mac OS. I checked my settings and they were definitely "Never" for Hard drive sleep, but I suspected that it was napping anyway. One time I went to the server and the green light on the front was pulsing on and off, then when I moved the mouse the drive spun up and light stopped blinking. I'm sure it was sleeping even though the Energy Saver settings didn't allow this.

So I set up another old OS9 machine I had available, formatted the drive and installed a fresh copy of OS9, immediately setting up Energy Saver to Never on the hard drive sleep. Another thing I made sure of was to set Software Update to manual so the server wouldn't try to search for updates every week.

Since I did this we've had no client disconnections. Maybe I fixed some other problem with the new OS, maybe the energy saver prefs had got messed up. Who knows, anyway this may help someone so I wanted to pst it in case.
 
Top