UT2004 crashing repeatingly

Damrod

Registered
So, I got the UT2004 DVD from my brother-in-law before he went on holiday last weekend. I installed it on my G4 that runs 10.4.1 and after a more or less short period of time it crashes. Most of the time it quites with an error to the Finder, but sometimes it is unrecoverable. I installed the latest patch, but nothing changed. Any ideas or news about that? Is it a problem with Tiger?

It seems that when it quits with an error, it's a bad memory access, but I might be wron. When I get such an error again, I will make a screenshot of it and post it here. But any help is highly appriciated. :)

EDIT: Expirienced another crash just some seconds ago and captured the message
 

Attachments

Damrod

Registered
MacMediaGuru said:
Download and install OS 10.4.2 and see if that helps.
I already did yesterday about 30 minutes after it was available through softwareupdate. Still crashed :(

JetwingX said:
or better yet, reinstall UT.
Trash "Unreal Tournament 2004.app"
Grab the new installer:
http://www.macsoftgames.com/products/ut2k4/support/UT2004-mac-updated-installer.tar.bz2

reinstall UT 2k4

add the new patch:
http://www.macgamefiles.com/detail.php?item=18155

and see if that works

If you are worried that you will lose your game info, you don't have to because that is stored in your home folder
This sounds promising. New installer? Will try this when I come home from work today. :)
 

Damrod

Registered
Does not help either... I mailed the MacSoft support about the problem, I wonder what they will answer
 

Damrod

Registered
Woe is me... :(

The suppport guy said, Unreal can not freeze the whole system. It must be a hardware or system problem. I'm afraid it's the first...
 

Krevinek

Evil PPC Tweaker
This is definitely strange, as I installed straight off the DVD, patched, and am running 10.4.1 with zero issues. Have had people playing for 2-3 hours without a single glitch. What is your RAM situation? Have you had RAM installed from places other than Apple, and if so, whom?
 

Damrod

Registered
I have 768MB RAM total, 256MB shipped with it and I put in 512MB later. I bought it from the same place I got the G4 from, which is Gravis (No, not Advanced Gravs, the Gamepad and Jostick manufacturer. Gravis is the biggest non-Apple retail store here in Germany)

Back when I bought it in 03, I bought a Hardware Security pack with it. Something like the Apple Care Protection plan by Gravis. I think I'll turn it in next week and let them check the machine. If something is wrong with the hardware, they will replace it for free.

I'm pretty sure it's the graphics card. I have that problem with all 'modern' applications that really go into 3D. Warcraft 3, Jedi Academy, Jedi Knight II, UT 2004, UT 2003... I had situations where the RAM was used basically to the last byte and nothing happened. But who knows... If it's the graphics card, I'll get a better one for free :)
 

JetwingX

iWork for Apple <3
i have another idea for you.

make a new user. log in to that new user, and try playing. if you still have the same problem, it is probably hardware
 

Damrod

Registered
JetwingX said:
i have another idea for you.

make a new user. log in to that new user, and try playing. if you still have the same problem, it is probably hardware
I tried that, but expirienced another unrecoverable.

So my G4 is going in next monday
 

Krevinek

Evil PPC Tweaker
Yeah, sounds like a graphics card problem... I used to get lockups with my Radeon 7000 on my 8600, although that was because I was lacking a case fan at the time, and running the machine 24/7 for months. So it was little wonder that the card finally overheated one day and locked the machine up.
 
Top