vi and emacs say don't use vt100

travelgz

Registered
Does anyone know why when I type vi or emacs I get error saying that vt100 is not an acceptable terminal (it does say "acceptable" but something like that). And of course, it doesn't run.

anyone know why?

Thanks
G
 

tismey

Official Bartender
Have you got 'Strict VT100 Emulation' checked under Preferences>Emulation ? You'll notice it says that this is 'not normally desirable', and I believe some systems don't like it. TRy unchecking this box and see if this helps.
 

travelgz

Registered
No, I didn't have it checked. So that can't be it. Is vt100 not desirable? I believe that's what I have on my linux machine. Is there something else I should use, and if so, how do I change my user to use that?

Thanks!
G
 

blb

`'
vt100 should be just fine:

Code:
nabu:/Users/blb $ echo $TERM
vt100
then running vi or emacs, I see no complaint at all. Are the vi and emacs you are running the Apple-provided versions? Is there anything odd in your environment?
 

travelgz

Registered
This is the relevant part of my environment variables for the term cap. Does anyone see any problems here that might indicate why vi (not vim) and emacs don't work? vi said: ex/vi: vt100: unknown terminal type

And yes, I am using vi from mac (though I installed vim, I wonder if that had any effect; vim works).

TERM=vt100
TERMCAP=$'d0|vt100|vt100-am|vt100am|dec vt100:'
TERM_PROGRAM=Apple_Terminal
TERM_PROGRAM_VERSION=57

G
 

blb

`'
(I have vim installed as well, and working).

I think, unless vBulletin modified your TERMCAP listing, that's the problem. I just tried setting my TERMCAP to what you listed, and saw the same error.

Which shell are you using? If the default (tcsh) did you modify any of the /etc/csh* or /usr/share/init/tcsh files? The '$' at the beginning of the TERMCAP setting is kinda suspicious...

FYI, my TERMCAP is a bit longer (technically, this is all one line):

Code:
TERMCAP=d0|vt100|vt100-am|vt100am|dec vt100:   
:do=^J:co#80:li#24:cl=\E[;H\E[2J:sf=2*\ED:     
:le=^H:bs:am:cm=5\E[%i%d;%dH:nd=2\E[C:up=2\E[A:
:ce=3\E[K:cd=50\E[J:so=2\E[7m:se=2\E[m:us=2\E[4m:ue=2\E[m:     
:md=2\E[1m:mr=2\E[7m:mb=2\E[5m:me=2\E[m:       
:rf=/usr/share/tabset/vt100:   
:rs=\E>\E[?3l\E[?4l\E[?5l\E[?7h\E[?8h\E[;r\E[0m\E(B\E)B\E[2J:   :ks=\E[?1h\E=:ke=\E[?1l\E>:    
:ku=\EOA:kd=\EOB:kr=\EOC:kl=\EOD:kb=^H:
:ho=\E[H:k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:pt:sr=2*\EM:vt#3:xn:   :sc=\E7:rc=\E8:cs=\E[%i%d;%dr:
 

travelgz

Registered
Well, I recently switched to bash from tcsh, but my vi/emacs/vt100 problem persisted since before that.

So can anyone copy and paste their .termcap for me so I can have any hope of running vi? It's important just because I need to use vi when editing SQL code in Mysql console (unless someone can tell me how to use vim in mysql).

Or does .termcap not applicable in bash environment?

THanks!
G
 

howardm4

Registered
Emacs and vi get their primary information from the TERM variable.

The terminal definition lives in /usr/share/misc/termcap and
that keys into the TERM setting.

Emacs works just fine for me (I'm not a vi guy) but all
I have is TERM set to either vt100 or xterm.

As a test, unsetenv TERMCAP and temporarily move
any .termcap files/dir under ~ out of the way.

Now if I can only get font lock colors to work properly in the
Terminal.app :(
 
Top