VirtualBox and head scratching..

fjdouse

UNIX - Live Free or Die
After trying VMWare and Parallels and not getting acceptable performance in Vista, I switched to VirtualBox last year and have been very happy with it. I decided to see what the difference is running it via BootCamp, apart from Aero it wasn't any faster really so I did a full system restore via Time Machine.

I did it twice because the hidden system filestructure in the root of the Mac drive was exposed, I eventually hid them manually with 'chflags'. Ok.

Fired up VirtualBox and I could not get Vista online. I've never used anything but the default network VBox settings and it's always worked fine. Inside Vista, it can see the VBOXSVR share with no problems, when I get Vista to diagnose the problem it says "Cannot communicate with primary DNS Server(10.0.2.3)
Network diagnostics pinged the remote but did not receive a response."

I can't find anyone else who has this problem except here:
http://forums.virtualbox.org/viewtopic.php?p=3700&sid=8539b727043cd87566cb0f9e45f07b23

Notice with wonder at the overwhelming responses! I believe that is the correct IP of the VBox DNS server.

I installed another copy of Vista, then WindowsXP with the same problem. I then copied the VM to my partner's MacBook and it runs fine for her. So it's got to be something to do with MY MacBook.

I reinstalled again, same problem. I've not set any preferences with the firewall.

I found a workaround by installing a second virtual network card but I've not had to do this before.

Anyone else had this problem or have any insights or ideas? What could make it change like that?
 

Giaguara

Chmod 760
Staff member
Mod
Is that DNS part of your router etc or how is the DNS supplied?
Did you have the same issue in Fusion or Parallels too?
Do you have vbox tools (whatever they are called) installed?

You got as much responses from vbox support forums as I did - I had some guru meditation errors, also around the same time, yet no replies... :)
 

fjdouse

UNIX - Live Free or Die
Yeah, I'm so flooded with replies I'm swamped!

The DNS setup is done by VirtualBox and is (was) the default settings. Yes the tools were installed. The VM worked flawlessly when copied to another Mac on the same network.

I fixed it by adding a new adaptor which uses the host's airport rather than NAT. Just cannot figure out why the default setting stopped working. A puzzle.

And yes, everything ran fine with the default settings in Parallels and VMWare, but the 'conventional' wisdom as to why these products are supposed to be better than VirtualBox eludes me. While trying to determine the problem, I tested boot speeds, app loading times etc. in all three products and found VirtualBox to be superior with Vista.
 

gmcnaughton

Registered
I had the same problem with VirtualBox: I could ping IPs directly, but domain names would not resolve from inside my VMs. This thread provided some answers:

http://forums.virtualbox.org/viewtopic.php?f=3&p=64065

If DNS lookup doesn't work in your Guest, then your Host's primary DNS doesn't work, or is unreachable. Your Host can automatically switch to the second DNS server when the primary fails, but VirtualBox cannot do this. Try switching your Primary and Secondary DNS entries in the host, boot the VM and try again.

I'm running WinXP as the host, and Ubuntu and Windows 7 images. DNS resolution was failing from inside both VMs.

Using ipconfig /all and nslookup, I verified that both my primary/secondary DNS servers were offline, and the host OS (WinXP) was failing over to a tertiary DNS server attached to my wireless connection. VirtualBoy is apparently not able to failover as gracefully.

This also explains why it may work one day but not the next, depending on whether one of your ISP's DNS servers is having problems.
 
Top