Volumes not mounting anymore under OS 9

nowall

Registered
(G4 AGP, OS 9.0.4, MiroMotion DC30+, Adaptec UW2940 and Adaptec SCSI adapter installed). Hi, i have 3 problems:
1) i have an internal UW SCSI 20Gb HD attached to my 2940UW Adaptec card (ROM flashed to most recent version). Its partitions didn't mount @startup under 9 > i had the habit to use FWB Mounter to mount them,'twas not a problem.
Under OSX PB, no way to mount them, even to SEE them (Techtool, Norton, etc..)
any idea to mount them?
2) have a 20Gb USB LaCie external Gb. Can see and browse it, but volume is locked (in admin mode/File sharing enabled).
Any idea to unlock it?
3)when rebooting on OS9 Partition, all volumes, except OS9 and the one which contains OSXPB, are unavailable. They've all been regrouped as "folders"in OSX's partition. when I open such a folder, all i see is "automount.disk" or something, all files are gone!!! (but perfectly available under OSX!)
any idea how to access my volume again under OS9?
thx ;-)
 

foo

Registered
loads of people are having the same problem, it has something to do with HFS partitions not being fully reconised in OS X. The drive is there, OS X just makes it invisable.

Apparently Disk Warrior from ALsoft can sort it out, I can't guarantee it, I am waiting for my copy 8)

If you find another way, please let us know.

foo
 

nowall

Registered
I'm happy to say ya that the problem is solved.

i simply re-installed Norton (v5.0.3) on the MacOS9 volume, then restarted under OS 9.0.4, with minimum configuration loaded (but with the Norton extension of course).

Then ran Norton Disk Doctoron all "disappeared" volume (which it could see, without being able to mount them), with all checking options and automatic problems fixation enabled.

then i sat in front of the screen and watched the process bar...

on every partition, same problem detected: "root file invisible".
But easily solvable by this dear Dr Norton. So then every partition mounted one after the other, without problem, without any ressources corrupted..

i must admit that i haven't restarted (either under 9 nor X) since then, so perhaps the problem will come again later. But no matter since it seems undestructive.

If it comes again i will repost some comments, if not, consider that everything is ok;-)


see ya
 

nowall

Registered
just an addendum:

i had a 2nd HD attached 2 an Adaptec 2940UW, and, before running Norton, no soft at all (Norton, FWB, Disk1st Aid, etc..) could even SEE the partitions of the Adaptec chain (bus 2).

after running Norton and recovering my partitions (of the ATA normal G4 drive), i gained access to the Adaptec bus again, through the already mentioned soft.

I guess the problem of invisible volumes could come from the presence of the 2940UW car, since the user who have this problem often have this card.
So, if Norton doesn't work, i would advice to retry all what you would have tried until then, but WITHOUT the Adaptec card.
A friend reported me that he couldn't even INSTALL OSX beta with the 2940UW plugged-in, and that removing it resolved all.

by the way, if you have this problem of disappearing volumes, don't panic! whatever you do, even if my solution doesn't work, the main thing is that your invisible data is safe, UNCORRUPTED!

oh, another thing: i tried to copy (under X) Norton and other HD utilities (which were on an invisible partition, on the OS9 volume) in order to be able to have access to them under 9 > catastrophy, files had lost all creator/type ressource, they were just blank useless files. So don't Norton from another place, just do a clean install on the OS9 startup volume.

that's all folk;-)


PS OSX
in the desktop, in Next's browser mode, if you want to open a folder in a new window (in order to drag something in it for example), double-click it with ALT down > the browser will remain as it is, and a new window, in icon mode, wil open
 

foo

Registered
yeah - I knew all the goodies were there, I had spotted them in sherlock, I just gotta hang tough till Disk Warrior arrives.

Fortunately I backed up everything onto a spare firewire drive, which I am using with my PowerBook. The frustration is a bitch though, some of the other threads I have read, said they have to do it everytime they switch back to OS 9.

This will be a good bug for Apple to crush ASAP.

PS: I like the shift click minimise for slow motion minimising, it's completely pointless, but has some weird hypnotic attraction.

foo
 

ahammock

Registered
HARDWARE:
-------------------------------------
PowerMac 9600
PowerLogix 350Mhz G3 upgrade
192 Mb RAM
2 Gb SCSI drive (SCSI 0, OEM drive supplied by Apple)
100Mb ZIP drive (SCSI 1, external SCSI bus)
Sonnet Tempo ATA/66 PCI controller + Maxtor 15Gb IDE HD (SCSI 2, PCI slot)

SOFTWARE:
-------------------------------------
MacOS 9
MacOS X Public Beta

PROBLEM:
-------------------------------------
15Gb HD, 3 x 5Gb partitions, fully visible under OS 9 but invisible to MacOS X Public Beta

COMMENTS:
-------------------------------------
Sonnet Technologies are still waiting on there copy of Public Beta so they were not able to help me at this time. MacOS X can see all of the partitions on my OEM drive (connected to the motherboard's SCSI bus), but it can't see the IDE drive connected to the adapter in a PCI slot at all.

MacOS 9 sees both drives, and thinks they are both SCSI drives. I tried unplugging the OEM drive (SCSI 0), hoping the PCI card would reconfigure itself as the default drive.

No luck so far. Anyone else?
 

foo

Registered
Norton Utilities for Macintosh, Version 6.0 Public Beta is free 1.5 mb download and it fixes it 8)
 
Top