Wacky G3 problems

LordOphidian

Adjutant On-Line
Ok, so the other day (monday) I need to reboot into OS 9 to write some files to my floppy drive (I have the G3 333 Biege tower, UW SCSI 9gig) and it boots off a secondary (old as hell) 500 meg scsi drive that has os 9.1 on it. So I thought i just picked the wrong hd in the Start Up Disk pane, so I go to start up disk and guess what, the only disk it shows is the 500 meg drive. So I reboot and try using the Open Apple-Option-Shift-Delete key combo to select a diffrent drive to boot from, but no go.. the only hd it sees is the 500 meg.

Alright, well I switch to the internal video from my Rage Orion card so that I can test out somethings in OpenFirmware but low and behold, it boots from the 500 meg drive and I can see my 9 gig disk. But the resolution and display is wacked out becuase it thinks I still have a monitor connected to the other card and windows appear off the screen some times. So I select the 9 gig drive to boot from and reboot, works fine. I write my files and then shut down to switch video cards. I do so and it boots off of the 500 meg drive again (wtf???) and it can't see the 9 gig. I test a few more times and sure enough.. it depends on which video card I am using, as to wether it can see my 9 gig disk or not.

So I take out the Orion assuming something is wrong with the card, but after I reboot it can't see the 9 gig any more from the 500 meg drive with the internal video. So I put the card back in and try booting from the X cd rom. No luck, no luck with the the 9.1 disk either. So I rearange all of the PCI cards and try again. Now it can't even seen the 500 meg drive, which is on the onboard scsi bus. I arange them back to the order they were in before and its still the same. But now I can boot off a cd rom atleast. I try running some of the tools on the cd, Disk First Aid, and the disk set up util, but nothing can see my hd's.

So now I can boot from a cdrom but that is it. I have looked in the OpenFirmware and it can see my UW scsi card (Apple53C875Card) but no disks under it, and it can see the onboard scsi chips but no drives under them either, so I am at a loss as to what happend. Any one have any ideas what could be wrong? Or how to fix it?

I guess its my fault for rebooting out of X eh ;)
 

themacko

Barking at the moon.
I'm completely lost. LOL. I don't have any idea about SCSI, sorry boss.

I did notice that you're from Mesa though! Are you gonna be at the Apple Store opening this saturday at the Chandler Fashion Center?
 

LordOphidian

Adjutant On-Line
Shit yeah man. Bright and early. The Apple Rep to ASU says they are expecting tons of people there so get there early.
 

LordOphidian

Adjutant On-Line
Well after picking up an external scsi drive from my uncle and using it to boot the system, I can get my computer to boot right... which is cool but the problem is that it only boots right every so often, say 5 or 6 boots on average. The rest of the time it seems that my UW SCSI card (the Apple supplied ATTO card) and one of my other pci cards conflict or something (its random and includes some of the chips that are built onto the mother board but are also on the pci bus. How damn annoying.

I suspect it may be the SCSI card, which i guess it wouldn't be too hard to replace. Anyone know the prices of bootable UW scsi cards out there for macs these days?
 

LordOphidian

Adjutant On-Line
Well I thought I almost had it working, but last night netinfo lost its mind and started saying that localhost resolved to 0.0.0.0 and that the dns servers were, localhost. So basicaly it removed me from the net. I tried restarting netinfo from the netinfo manager but it wouldn't restart so I rebooted the computer.

When it finaly rebooted in to OS X it took about 20 minutes trying to start netinfo and then it came up with the set up agent, but after running through the set up agent again, it still is reporting the wrong dns servers and that localhost resolves to 0.0.0.0. Bah!
 
Top