webdav, OS X and Windows 2000

themacnut

Registered
I've set up webdav on my personal Linux server. For those not familiar with it, it enables you to have iDisk-like access to the machine where webdav is set up.

It works like a charm on my G5 running Tiger at home-I just go "Connect to Server", put in the url for my server, type in username and password, and it pops up on my desktop just like iDisk would.

However, on my Windows 2000 machine at work, it just gives me a "this folder does not appear to be valid" error. Have any of you tried connecting to a webdav server on Windows 2000? Have you ever made it work?

On the Win2k box I've tried connecting through the My Network Places icon, and through the Web Folder option in IE. The result is the same either way.
 

elander

Registered
I've had this problem myself, as my old job has a very mixed bunch of operating systems. Here's how I solved it then:

In Windows 2000 you should be able to connect by adding the webdav folder as a Network Place.

It doesn't really work in XP, so there you have to add it as a network volume instead, i.e "X:\" or similar. It might be that a recent service pack has messed things up in Win2k too, so try the volume thing.

I've never gotten it to work through IE though.
 

themacnut

Registered
Trying to add it as a network volume didn't work, it insists on me adding at as a new Network Place (web folder). Any other ideas?
 

elander

Registered
I've seen some indications that it might depend on the authentication mechanism: Basic+SSL seems to work, whereas Digest does not.

I've also seen that you need to enable something called "WebClient" (whatever that is, I don't have a Windows 'puter to try it on). From Microsofts webdav support page:

To check the status, or to enable the WebClient service on a WebDAV client machine
1. From the Start menu, point to Administrative Tools, and click Computer Management.
2. In the details pane, double-click Services and Applications.
3. Double-click Services.
4. Scroll down, right-click WebClient, and click Properties.
5. In the Startup type list box, click Automatic.
6. Click Apply.
7. In the Service status section, click Start.
8. Click OK.

If you've already tried these, come back and let me know, and I'll see if I can find something else to try... ;)
 
Top