weird problem


Hey everyone, I've searched and couldn't find anything like this, so here it is...

I just bought a used imac with Tiger installed on it, and the person I bought it off started it for me and showed me that all was good and everything, it started fine, and so I brought it home and started it, and there's that flashing ? icon. I tried starting it a few more times and so I thought, okay, it must have been a mistake, I'll talk to the guy later... and the next day I randomly turned it on to test an outlet to see if the outlet worked, lol, and it came on and started up fine. So I went to the startup disc to specify that I wanted it to start with OS X, and restarted and it's back to the flashing ? again. I started it with my OS 9 install cd just so I could tell it to start with OS X, and it didn't have it listed to start up with... so I restarted and it works again. It's really weird, I'm not mac-stupid, but I really don't understand why it's doing this. It's like sometimes it has a system, sometimes it doesn't :s
And also, classic isn't working. It says I need to update Quicktime or something to start it, but how can I update it without starting it? So yea.. I can't start it with OS 9 either.
Can anyone tell me how to fix this?
Your best bet is simply to clean reinstall Tiger, as its just a new computer you hopefully won't have to much to restore to get it back the way you had it. It sounds like the previous owner must have done something to the system files, and you'd be best off reinstalling and starting over.