weird purple, mirrored, shadow reflections in Xcode's xib editor

the1337moderate

Registered
Anyone like my best shot at a descriptive title? I thought I'd deviate from the go-to phrase "HELP ME, IT'S BROKE". I tried searching for help with this, but I believe it is so abstract of an issue that the almighty google doesn't even know what I'm talking about. They say a picture speaks a thousands words; I took a screenshot. Any suggestions on how to make them go away would be greatly appreciated.

https://www.dropbox.com/s/h2cjeo9f7oumjur/Screen Shot 2013-07-29 at 11.58.05 PM.png

Screen Shot 2013-07-29 at 11.58.05 PM.png


For full disclosure:
* Macbook mid-2010 model
* OS X 10.8.4
* 2.4GHz C2D
* 8GB RAM
* 500GB HDD
* Xcode Version 4.6.3 (4H1503)

Apples's developer forum is down right now or else I would be asking there also.
 
Last edited:

szymczyk

Registered
I can recreate the shadows you're seeing in the screenshot if I enable the Core Animation layer for the tab view. If you're not using Core Animation, you can turn off the Core Animation layer for the tab view, and the problem should go away. On the right side of your screenshot, there are eight buttons above the word Tab View. Click the rightmost button to access the view effects inspector, which handles Core Animation effects. At the top of the view effects inspector, you should see a Core Animation section at the top with a series of checkboxes. If you have the tab view selected, there should be two checkboxes: one for the tab view and one for the document window's view. Deselect the checkbox for the tab view and the shadows should go away.

If you are using Core Animation effects for the tab view in your application, you're going to have to live with the shadows when you select the tab view. When I tried recreating your problem, the shadows were there when I selected the tab view. Selecting one of the tab view's subviews from the jump bar made the shadows disappear.

By the way, Apple's paid developer forums are back online.
 

the1337moderate

Registered
Thank you so much. I was driving myself bonkers trying to figure out what I had done wrong.

On a secondary note, and this has nothing in common with the main post, I am hoping that you may be able to help me out a little bit more. Please review the following link: http://stackoverflow.com/q/18095160/2659234
 
Top