What gives?!?! Tiger, XP, SMB, & afs

LukewantTiPbook

Registered
So I have tried unfruitfully for a Month to get my Powerbook and my XP workstation at work to talk. The powerbook does not see ANY windows machines on the newtwork, so I cannot browse to the XP machine. I tried the smb://server/share but that always resulted in a username/password error. Then I happen to turn off my XP afs mapping program from NC State (I am a student and NCSU uses a unix system with afs).

So, my question is: does anyone know wtf is going on between my XP box afs and SMB on the Powerbook?!?!?!? I would like to use both on the simultaniously (espcially seeing as Tiger upgrade broke openafs).

Thanks,
Lucas
 

nixgeek

Mac of the SubGenius! :-)
Did you enable Windows Sharing on the Mac from the System Preferences-->Sharing?
 

LukewantTiPbook

Registered
Yeap,

Cycled it on and off several times. Also cycled personal file sharing and the firewalls on both machines.
 

HomunQlus

Artifical Lifeform
When XP has the Firewall in the Network Settings enabled, you cannot access that box with a Mac or from Samba. Tried that several times, it just doesn't work. If so, try to deactivate the Firewall first in Windows, if there's another Firewall installed deactivate that one too and see if you can access that box then.

And for Samba: The 3.x releases are known to have some serious issues. So you must get rid of that. Install the latest Samba, which is 2.2.12. Grab it here. After that configure your smb.conf accordingly with the folders you want to access. If you want to upload something with samba, don't forget to change the permissions of that folder to 777 and set "writable = yes" in the config file.

That should do the trick.

I have Samba 2.2.12 running (build from source) on my Fedora box and I can access it from my Mac without any problems.
 
Top