What if share name has a space in it...

jabhome

Registered
OK, so I can mount smb://hc1/apps/ no problem using 10.1 over a NT4 network.

I have tried smb://hc1/hchc%20data/ where %20 represents the space in the sharename but this is not working out. Has anyone else ran into this type of an issue. If so what did you do about, aside from renaming the share name on the Windows machine.

Thanks,
Jason
 

jabhome

Registered
i.e. I have two printers located at

/servername/hp4m/
/servername/hp/

When I use the smb://domain;login@servername/hp4m/ command and attempt to connect I get the"no shared file system" error. Well a printer is not a file system but I would still expect to be able to share the printer. Am I wrong, can I not print from my iBook over the Windows network.

By the way, those error messages that Apple has provided are worthless. Whatever the problem, you get the same error.

Thanks,
Jason
 

Red Phoenix

Registered
As far as I know, Apple's SMB support does not extend to printers. I think we'll have to wait for USB Printer Serving to come to OS X before we can even consider printing to Windows printers...
 

jabhome

Registered
Any thoughts on the spacing issue. Is this a flaw with smb that will require a fix from apple. Or is there some type of obvious work around that I am missing.

Thanks for the info about the printing,
Jason
 

Red Phoenix

Registered
I don't know how to deal with it, personally. I tried connecting to a drive "MAIN DRIVE", and attempted "MAIN%20DRIVE" and "MAIN\ DRIVE" before giving up and doing what you don't want to do. I am not completely sure that this a "bug" on Apple's part, though. Windows had to do some really weird things to add spaces into file names. I have done some reading on this, and some versions of Windows have a problem with spaces in names.

If you're set on having spaces in the name, try something like "MAIN_DRIVE" (underscores in place of spaces) or "MAINDRIVE" (take out the spaces). I haven't tried them, but they might work.
 
Top