what is going on?!?

omegaroot

Apprentice Codemonkey
Im having the most disturbing problem. Upon restarting my machine (OS 10.1 5G64) religously the OS returns incorrect DHCP info or no info from my ISP, AT&T (does this matter?). To remedy this I have to continually restart sometimes taking 6 or 7 restarts to finally get the DHCP info. Major pain in my...

This didnt happen in 10.0.4 or 9.x

A side note, when this happens and I do a 'sudo shutdown now' (I restart so rarely I like to run fsck when i do). When the console appears I normally see my node name in parenthesis and the command line. When the DHCP issue is at play i see nothing for this console, i type fsck and i can hear the drive going through its paces and then type reboot and it works. Nothing is echo'ed to the screen though, side issue? I dont know it always happens with the DHCP issue.

I love 10.1 but this is rediculous. So far as I can tell my only option is to do a clean install when my 10.1 cd + dev tools arrive with my october mailing (pays to be an ADC student developer).

Can anyone offer some insight into this? Why this might happen? Anyway to avoid it in the future? Seen it before? A solution would be great, im not fond of the thought of destroying everything and starting from scratch :confused:
 

Pascal

Official visitor
I don't really have any serious insight, but I can at least certify that I don't have this problem here running Mac OS X (10.0.3 updated to 10.0.4 then to 10.1).

Could it be that you installed some interim betas of Mac OS 10.1 on your Mac ??? Maybe they hosed some important part of the OS...
 

omegaroot

Apprentice Codemonkey
I guess thats a possibility, I have a somewhat similar upgrade path to yours, Pascal. Aside from the 5G40 in there :D I don't recall if I experienced this problem while running that version though.

10.0.0 -> 10.0.3 -> 10.0.4 -> 10.1 (5G40) -> 10.1 (5G64)
 

Pascal

Official visitor
Originally posted by omegaroot
I don't recall if I experienced this problem while running that version though.
I would say that this seemingly innocuous sentence is very telling ! :D I think that you did not have those problem then... otherwise you would have noticed !
 

omegaroot

Apprentice Codemonkey
hehe...
Actually your response caused me to think very hard! Nothing happened. So I tried again and remembered that while running 5G40 I was also running a Carracho server (for eduacationa purposes of course :D which is how I eventually got the 5G64 upgrade image).

But anyhoo I brought the server down every couple of days or so cause the logs would fill up with:

"0.0.0.0 Connection Established. "
"0.0.0.0 Connection Closed."

Checked the drives and reset the Block Sync on the modem. On occasion the server didn't go up for days at a time cause it would be so frustrating to deal with the DHCP deal.
 

omegaroot

Apprentice Codemonkey
I feel really stupid now!!!
I solved my own problem!!
I hate that!!!

This was getting so frustrating I thought I might take a few shots in the dark. Remembering back to my Legacy Mac OS troubleshooting days, reseting the PRAM was one of the first things you did before even thinking of a clean system install.Well Im not sure how or if OS X even uses the PRAM anymore but reseting it fixed everything!

I restarted 6 times and each time DHCP info was assigned perfectly. The console after shutting down agua was perfect. My mac even remembered my monitors suggested screen resolutions (this had disappeared long ago and actually only showed unsupported resolutions). To test it even further, I got a devilish look on my face, looked around and then tapped the restart button on front of the case, with apps running... She restarted flawlessly, DHCP and all!!!!!!!

Maybe my mac was a little punch drunk from frequent UT crashes in 9.2.1 (UT was notorious for crashes while in opengl mode with less then 180 megs. allocated to it) Which caused the PRAM to become corupt? Or booting between X and 9 corrupted it? Is corruption of the PRAM possible? Thats something ill have to bring up on Apples darwin development mailing list I suppose. That and if X/Darwin use the PRAM at all (they are trying to maintain some hardware portability in darwin - the foundation of X).

ahh... the little things will get you every time I guess...
 

Pascal

Official visitor
Originally posted by omegaroot
Is corruption of the PRAM possible?
Absolutely ! And I agree : the likely cause of your PRAM corruption is your numerous Mac OS 9 crashes.
Thats something ill have to bring up on Apples darwin development mailing list I suppose. That and if X/Darwin use the PRAM at all (they are trying to maintain some hardware portability in darwin - the foundation of X)
Interesting question. Keep us posted !
 

The Munk

Registered
so when i put 10.1 on here, I should reset the PRAM before i do it??? I don't want things to get all screwy on me. What if i reset it after? would that be a problem?
 

omegaroot

Apprentice Codemonkey
I would suggest doing a PRAM reset just before you install 10.1 or anytime you have a really nasty crash. (i.e. the only method of restarting the computer is pulling the plug, or killing the power supply, rare.). It doesnt hurt, only help. In X I havent seen it affect any preferences (cause most are stored in .plists now) but in 9.x after a PRAM you had the minor annoyance of having to reset your clock and control panel settings. Its no big deal.

If your wondering Munk, how to do a PRAM reset. You restart, right when the screen turns black hold down [ option + command + P + R ] until you hear the computer 'chime' again and release...
 

Pascal

Official visitor
Then again, PRAM must still be used since its corruption affected the computer's behavior in Mac OS X ! ;)

As for PRAM reset, I had read in a few Mac books or mags that one should hold the key combination you describe long enough so as to force the computer into 2 or 3 consecutive restart chimes... They explained that this would insure a complete clearing of the PRAM... Is it really necessary ? I don't know : a PRAM reset is so rarely needed !!!
 

omegaroot

Apprentice Codemonkey
Sorry for the great length of time required for a response :D
I know I promised to post my replies from 'darwin-development' mailing list and I will, but I dont have time right now... gotta go to class...

My system has been down for two days!! Either the same problem or a new one, idunno I was so frustrated I was tired of argueing and just did a clean install... I think a lot of my problems were stemming from a beta driver running an adaptec 39160 + quantum drive attached to it. What went down was one morning while backing up my most important data to the quantum the beta driver kicked the drive! 6.7 GB gone... hours and hours of work totally inaccessible, everything from my taxes to any essay I have ever written. :(

Thanks Adaptec!! I hope you read this! This is crap, I buy a $400 HBA and still no final drivers yet! WTF!! its been almost a year since the last driver release.

I think I learned a hard lesson, I should have spent the extra $100 on an ATTO. Well in any case I did a clean install, removed the adaptec + quantum drive and the machine is REALLY fast now (clean install!) and havent had a problem yet, everything is working flawlessly... I apologize to Apple for hinting it may have ever been their fault...
 

theed

Registered
I've had similar creeping problems, and they are aftened followed shortly by a catastrophic HD failure. I wouldn't be quite so quick to blame adaptec for this. ... and it was a noted beta driver. Even if it is them, they tried to let you know.

Anyway, I would continue to not trust that drive for a while in any configuration. And the final word is that if you have any data you really care about, you need to save it on multiple copies of disparate media. One HD, One tape, and one CD would be a good solution. Data is fragile. I have lost much in my time. I feel your pain.

as for the PRAM ... I've had no such issues. And generally speaking, I'd never reset the PRAM unless you are experiencing wierdness. If you do have to screw with PRAM, Techtool is sweet. Allows you to revert your PRAM if necessary. Although it can also hose low level stuff like hours of runtime for a machine (odometer) that should never get reset. Powerful though. :)
 

omegaroot

Apprentice Codemonkey
I dont believe the HD will fail. Its just inaccessible (i.e. whenever it is accessed the OS goes into some infinite spinning cursor loop), its a brand new Quantum, Although its possible. Ive owned Quantums before and they are pretty good about that. Plus, both Disk Utility and Drive 10 have checked this drive and can't find anything wrong with it.... weird....

Im not blaiming Adaptec for what happened, I do realize its a beta driver. My complaint with Adaptec is ITS STILL A BETA DRIVER!!!! The version 1.0beta9 was release 8/8/01... I have patiently been awaiting this driver since OS X public beta, now im starting to lose my patience.

OS X being released should not have been a surprise, Ive known about it for at leaste a year, hence why I bought a DP machine.

This should have been the perfect chance for Adaptec to jump in a get a foot in the door on the possibility of an OS X server market, but they have dragged on and on instead.

btw, can anyone recommend upcoming software that handles low level formating / installs drivers that run well with quantum drives? Apples Disk Utility installs generic drivers for everything but the stock IBM drives and I hear Apples drivers cause High performance drivers to run very modestly
 

omegaroot

Apprentice Codemonkey
This was probably one of my best responses to my email to 'darwin-development' mailing list.

On Tuesday, October 2, 2001, at 06:55 PM, Mark wrote:

>Hi,
>
>I know this is probably off topic but please grant me an indulgence. Im new
>to the development world (Sophomore, Computer Science Major). I
>subscribed to this list to get a feel for the development world, terminology,
>etc...
>
>I have a question for anyone who is intimately familiar with OS X / darwin
>and Apple hardware. Hopefully someone from Apple can answer this for me.
>I would really appreciate it.
>
>1st.) Does OS X / darwin use the parameter ram (PRAM). If so what is
>stored there and how? Would this be handled by something low level,
>possibly by darwin? Or does this control reside exclusively in OS X?

Yes, the pram is used. It contains stuff used by both Open Firmware and by the OS. You can view the contents (although there's no reason to think it will make sense to you :-}) with the nvram command (see its man page for details). It has to be invoked by a 'root' user.

>2nd.) Is it possible for the PRAM to become corrupted? If so what would
>cause this, freeze during write? Wrong information being written to it? Or
>would hardware crash's cause this as well?

Yes. Any number of things, including those you mention. There's a key sequence you can use during the initial boot to reset the nvram (CMD-OPTION-R-P, all down at the same time, prior to the end of the boot-beep).

Hope this helps.

Regards,

Justin
----------------------------------------------------------------------------------------------

The nvram command was exactly what I was looking for! From it I was able to determine that 'default-gateway-ip' was stored in PRAM.
 
Top