'who' doesn't see terminal users


Notorious Olive Counter
On OS X 10.0, you can open a terminal, and try this:

<tt>[poppacrow:~] mark% who
mark console Mar 29 17:31 </tt>

'who' doesn't see you even though you are typing that at a terminal. If you ssh onto the computer from outside, it looks like this:

<tt>[poppacrow:~] mark% who
mark console Mar 29 17:31
mark ttyp3 Mar 29 21:27 (ultra5h.usask.ca)</tt>

Here I was only assigned ttyp3 because I was already on ttyp1 and ttyp2 with terminal.app.

I want people logging on to the computer with ssh to be able to tell which terminals are being used by whom, so that they can "talk" to one another. In PB, I turned on talk, and the console user could chat with people who were logged on remotely. Now who, w, talk etc. only see people who are logged in remotely, but not using terminal.app.

Anyone have any suggestions, hints...?
Hm. I don't remember that being an issue in the PB, so perhaps it's changed, but perhaps I just used finger. In which case, try finger--I'm pretty sure it worked for Terminal logons before...

'finger' only sees console and remote logins, just like 'who'. I'm pretty sure you're right though, that finger showed every login in the PB.

What bothers me is that 'talk mark ttyp1' (when ttyp1 is occupied from terminal.app) gives me

[Your party is not logged on]

and talk just hangs up.
Have you tried just 'w' instead of who?

I haven't checked yet to see what, or if, it aliases to, however it does give you a nice tabular listing of everyone logged onto your machine including tty numbers.
Have any of you tried logging in as root (from the main login)?

If I log in as root, everything seems to function normally. I can see each session (window) I have running under who and finger, and I can talk to root, even from other machines. If I don't have terminal.app running then 'talk' from a remote machine reports "User is refusing requests" which would be expected.

If I login as non-root (but main admin) then other funny things happen. If I try to 'mesg y' to accept talk sessions I get a "permission denied" on my tty file. I can su, then mesg y, or I can chown the tty file to my user and do a mesg y, but talk (and who) still doesn't see anything different (as reported). Then when I log in as root again, it chowns the tty files that I use back to root. It doesn't seem to mind chowing /dev/console correctly, but it wont chown the ttys...