Why is my iTunes in Hebrew?

dc lamb

New to mac, new to the forum. I've just installed Tiger and now my iTunes and Office Apps are in Hebrew! I've disabled all Hebrew fonts and that didn't work. Any ideas?
Funny! :)
go to System preferences (the dock icon with the apple and the lightswitch) and go to International in the topmost row. make sure your language is at the top.

macosx works like this (simplified):
whenever you start an application it checks this list and sees what is at the top. if the application supports this language then it goes with it. otherwise it will go with the language below the topmost. you probably, by some freak accident, have hebrew on top. if you would do a restart or logged out and in again that would mean that your whole system (finder etc) would be in hebrew and it would have been really hard to find the international preferences pane :)