Window Managers

AdmiralAK

Simply Daemonic
Hi to all.
Since OS X is essentially UNIX in its core I was wondering if anyone has stated any interest in porting window managers ( Open windows, KDE, GNOME, CDE, afterstep or whatever else there is) ???

Dont get me wrong I love aqua, but I hate stagnating on one kind of "view" for too long ( lol ... this expalins my huge collcetion of kaleidoscope schemes on my MacOS 9 machine :p)


Admiral
 

strobe

Puny Member
That's the difference between 'core' and all the crap you run on top of it. There is zero similarity between X11 window managers and the OS X WindowServer. Hell, the WindowServer doesn't even manage title bars (although it probably ought to).
 

gronos

Registered
While I may be wrong, my understanding is that with the core of OSX being essentially BSD Unix that recognizes the HFS+ file system (ie.Darwin), that by running Xfree86 under OSX you should be able to run GNOME or KDE desktop. I plan on at least trying it when I get my copy of OSX. I'd be surprised if someone hasn't tried it already. Any more info out there?

rich G.
 

strobe

Puny Member
Why concentrate on bringing crap to OS X instead of bringing excellence to other platforms?
 

zaustin

Member
Gnome doesn't yet work. It requires a bunch of linux libs that must be tweaked and recompiled for PPC/BSD support. I have XFree86 4.0 running on my OSX (4k17) with the Afterstep window manager. Other window managers that I have seen include twm (puke) and enlightenment (I think you have to install the full GNUDarwin distro to get enlightenment to work, but I'm not sure.)
 

justinsane

Registered
it would be nice to have X & Gnome/GTK so we can run stuff today while we work to get it ported. I don't know about all of you, but my computer is a tool. The more applications it runs, the more powerful a tool it is. This is why Mac OS X has the potential to be the best desktop OS ever--flexible power to run WIndows apps (as soon as Virtual PC runs in classic mode and latter native mode), MacOS in classic, Unix in shell, and perhaps GTK in X. I will have achieved Nerd-vana. Now where is that Python 2.0 port ? ;-)
 

strobe

Puny Member
It's only useful if you need that specific application.

For example no gnutella client works on the mac so people use LimeWire. The second a mac gnutella exists that works I would stop using LimeWire.

I don't consider a schizophrenic interface useful. A GUI is only useful if you have a single method to do common tasks. Given how chaotic X11 apps are, I much prefer the command line and avoid X11 like the plague. I only use X11 when absolutely necessary like reading a PDF.

If there are only a handful of X11 apps which we don't have a mac alternative for, why not just port those apps?
 

AdmiralAK

Simply Daemonic
Go yout limewire to work ???
How in God's name did u do that ???
I mean I installed the app, I run it but the stupid thing doesnt connect!
Sure it says " connecting " but then that disappears and I still have a red light
meaning that I am not connected :p


stupid limewire :p


Admiral
 

strobe

Puny Member
sounds like you're behind a firewall

assuming you know the gnutella protocol I'm sure you've checked this already
 

AdmiralAK

Simply Daemonic
I dont think I am behind a firewall.
No other app that requires firewall info has it and it works fine :p
I will look into it though.

Admiral
 

Jurneyman

Uber Geek.
Originally posted by strobe
Why concentrate on bringing crap to OS X instead of bringing excellence to other platforms?

Have you ever used X11, with a well designed wm? IMO, Enlightenment and Gnome, tricked out with GTK themes look's much better than Aqua. There are many, many X11 app's out there that kick the hell out of the app's I have seen bundled with OS X. And OS X is far from excellence when compaired to FreeBSD, or for that matter, some parts of linux.

If you are truly interested in helping OS X become a damn nice platform, Unix and Mac, then I think it is time you stoped being so negitave, and start being a bit positive.

Yes, X11 has some real crappy app's, but it has some real good apps as well.
 

tie

Registered
How does one install a GTK theme? I downloaded the AquaX theme and tried to install it by putting in my .gtkrc

include "/Volumes/Scratch/fink/stow/gtk-engines-0.10-1/share/themes/AquaX/gtk/gtkrc"

but it doesn't work. It says it can't find the library or something -- but there isn't a library included with AquaX, just a bunch of pixmaps and the gtkrc.

(And the same error occurs if I try to use one of the other themes included with gtk-engines, even those for which there is a library.)
 

tie

Registered
Yes, I would like to install a GTK theme for Xwindows (of course :) ). I have enlightenment running and I have installed gtk and gtk-engines via fink. I posted some screenshots over in the screenshot forum.

I assume the method is very similar to that for Linux, so maybe you can help.
 

Jurneyman

Uber Geek.
You are asking how to do this on what OS? Linux? (I hope).

http://gtk.themes.org/php/docs.phtml?docid=39 Should tell you how.

If youre trying to get GTK themes running on Aqua through some X server (XonX or what ever) I think your out of luck till more happens with porting over lib's and such.
 

tie

Registered
I am trying to get GTK themes to work for my XWindows installation on MacOS X. I have all the required libraries already installed. The theme I have downloaded is called AquaX and is supposed to make GTK widgets look like Aqua widgets. I have already downloaded and installed an Enlightenment theme called Aqua which makes window title bars look like MacOS X Aqua title bars.

The command line stuff didn't really work, though. I'll try installing gnome so I can use the gnome control center.
 

tie

Registered
Well, I downloaded gnome control center. It's really nice, letting you switch themes, window managers, and some other stuff. I haven't yet figured out how to install new themes but I can switch between the default themes.

It just does it by editing the .gtkrc in your home folder. For example, mine now looks like

-- THEME AUTO-WRITTEN DO NOT EDIT
include "/Volumes/Scratch/fink/share/themes/Pixmap/gtk/gtkrc"

include "/Users/breic/.gtkrc.mine"

# -- THEME AUTO-WRITTEN DO NOT EDIT
source "/Volumes/Scratch/fink/stow/gtk-engines-0.10-1/share/themes/Notif/gtk/gtkrc"

It is still giving some errors: can't find libnotif.so. There is no file called libnotif.so even though there is one called libnotif.la. But it seems to be at least partially working. (I've never used these themes before so I don't know what they are supposed to look like.)

[EDIT: The file libpixmap.so is what is needed to run gtk themes. I tried renaming libpixmap.la and it says it is the wrong kind of file. So I don't think themes are possible with the fink gtk installation.]
 

tie

Registered
Okay, sorry, but it isn't working after all. It is able to change colors and shapes of widgets, but it won't use the pixmaps. I have tried adding a module_path line and that doesn't work. I have also tried adding a pixmap_source (or whatever it is called; I forget now) line and that also doesn't work.
 
Top