WindowMaker

jcpowers21

Registered
I tried to install WindowMaker, I used the lm trick and copy the config files, but when i make it, this appears:

/usr/X11R6/lib -lX11 -lm
/usr/bin/ld: Undefined symbols:
__XErrorFunction
__XIOErrorFunction
__Xdebug
make[1]: *** [testgrad] Error 1
make: *** [all-recursive] Error 1

It will not let me do anything after this.
 

RacerX

Old Rhapsody User
The problem is that WindowMaker is designed for systems running X-Windows and has not been optimised for PPC systems with the Darwin kernel.I needs to be understood that Mac OS X is NOT Unix or Linux. Darwin is Mach 3.0 with a 4.4BSD interface layer. It is NOT 4.4BSD (or FreeBSD, or OpenBSD, or the like). On top of all that is Aqua/Quartz which is so completely different from X-Windows... I wouldn't know where to begin. GNUStep has spent the last 6 years trying to make what OPENSTEP had with display postscript, and they are no where close to finishing. Apple to display postscript and reworked it into display PDF with native OpenGL. X-Windows likes very weak compared to that (mainly because developement stopped on it a long time ago, and most developer don't even follow it interface rules any more, but what can you do).

Honestly, if you want/need WindowMaker, you better off compiling it from scratch on Darwin (which is free) with X-Windows on it. Way too much work to try on Mac OS X.
 
Top