After moving from ASIP 6.3 to X server the ability for PC to connect to the MAC server seems to have gone. They see the server in the domain but don't accept the password as a valid one. Yes it is the right password:)
Make sure that encrypted passwords is enabled in smb.conf file. More than likely OS X Server is using Samba to connect PCS.
I have the same problem with Windows 98. With Windows Me it works OK. I would like to modify the smb.conf file, if I knew where the heck it was.
SMB conf file: /usr/local/samba/lib/smb.conf

This feature can also be enabled through /Applications/Utilities/NetInfo Domain Setup (i.e. activate the Authentication Manager - be sure to be logged as *root*, at least for me it wouldn't accept the change otherwise).

Works nicely with Win98 & NT4.

Does anyone know how to use samba/MacOSX for Windows authentication and/or loginscripts... (i.e. as a domain controller)?
Thanks. Encrypted passwords is already set to yes. When I try to connect from Windows 98 (and Me now too), I am asked for a password, and the password I enter is rejected. I have turned on Guest access on the server.

I am having the same problem. In the server admin help it also suggests turning on clear text passwords. I remember seeing that setting somewhere but i cannot find it now. Even with encryption on it still does not let me log on, whats the deal?
Clear text passwords is a Windows thing, I think. Who knows anything about it?

I have just discovered that if I log in to Windows as a user that does not exist on the server, I can access the server no problem. Only when the user exists on the server does it ask for a password - and then the password is rejected.
Windows 95/98 send passwords in clear text by default. Windows NT and 2000 do not, but can be made to do so by editing the registry.

The WinNT key is: (Create it if it does not exist)


The W2k key is: (Create it if it does not exist)


To re-enable encrypted passwords, just set the value back to 0.