Wireless connection drop out (hardware failure?)

asuen435

Registered
I have a 500MHz Powerbook G4 with 512MB of RAM running Mac OS X 10.4.2.

I would lost wireless connection after about 40 min to a hour of use, while the wireless connection is out, the system profiler still shows AirPort card present (firmware version 9.52) but with no wireless network available. I have checked & confirmed that this is not caused by any outside signal interference such as 2.4gHz cordless phone nor any fault of the wireless router. So far the only fix is to put the powerbook in sleep mode for at least an hour, then it would regain the wireless connection for another 40 or so minutes. Restarting or shutting down/powering up or even rebooting in Mac OS 9 doesn't bring back the wireless connection. I tried using a Belkin 802.11g PC Card but it would show the card present but can not detect any wireless network. Everything else on the powerbook is functioning fine, I can connect to the internet without any problem with ethernet cable.

So far the troubleshooting procedures I've tried...

Checked & reseat the airport card.

Zapped the pram.

Reset PMU with the button on the back panel.

Re-install Tiger 10.4.2 (without retaining user settings).

Ran the Apple Hardware Diagnostic Disk that came with the Powerbook originally & passed all tests.

Backup battery seems to be functioning, the powerbook continue in sleep mode for about 1minute 15 sec without the main battery & unplugged.

Backup battery test performed by shut down, unplug and remove the main battery for 10 minutes, the date & time setting was still retained.

Charging of the backup battery was performed by removing the main battery & leave the powerbook plugged in for at least 10hrs.

It appears to be some kind of hardware issue. It's an old powerbook & I really don't want to spend a fortune to fix it but I would really like to get my wireless capability back. I would appreciated so much for some kind of help & pointers as to what might be malfunctioning. Thank you so much.
 

powermac

iMac Dual 2.0 17'
I am not sure, I have had some airport woes lately myself. I live in a house with like three other apartments, and everyone has a wireless network. I don't have a rock solid solution, in Airport Admin, I have tried different setting like changing the channel, and turn on and off interference robustness, etc.
Perhaps your problem involves the DCHP lease or something. Sorry not much help.
 

asuen435

Registered
I played with channel switching with my wireless router but I also lost wireless connection at my brother's apartment, while his powerbook ran without any problem (he has a snow base station). I have also lost wireless connection at my parents' house (same Belkin wireless hub as mine, and no other wireless network near by). I can pretty much rule out any issues with the wireless hub. The funny thing is, after acting up for 3 weeks then all of a sudden, it's been running without any wireless issue as I was just about to take it in to the genius bar at the Apple store. Well, go figures, lets just hope it stays that way.
 
Top