Wireless Drivers for PB G3 Series

shahn

Registered
I just installed OS 10.1 on my G3 series/266/256MB/40GB and I'm trying to install drivers for my Lucent Wavelan card.

As far as I can tell there are two common sources for these drivers. One is from "yuriwho" and the other is "rob mckeever" - actually, I think they are the same person.

In any event, the yuriwho installation package was recently updated for 10.1 When I run the ".dmg" file and the installation package, everything seems to go ok but when I reboot, the wireless driver is not installed.

I subsequently decided to try to replace the driver with "rob mckeever's" driver package. This is a little scarier since it appears as though I have to do some work with the CLI. I found the driver package "/system/library/extensions/wirelessdriver.kext" but I can't delete it!

Any suggestions?

Thanks!
 

cowgomoo

Registered
I know in OS 9 you don't even need the Wavelan driver. I tried installing it but it was much easier and seamless using Apple's built-in "AirPort PC Card" extension. Did Apple not develop a X-compatible version of this built-in driver? Hmmm...this may affect things gravely...
 

yuriwho

Registered
Try using the card in the upper PCMCIA card slot on your wallstreet, see if that works.

Do the lights blink on your card? If they do, the driver is installed correctly. You need to open the network preferences pane to select and configure the EN1 ethernet interface for the driver to work.

To delete the driver from the terminal type the following all on one line and then enter your password.

sudo rm -rf /System/Library/Extensions/WirelessDriver.kext



If you installed the 10.0.4 version of the driver on your Mac OSX 10.1 installation (against the advice of the readme) you will need to either re-install 10.1 or restore the 10.1 version of IOPCCardFamily.kext from /var/backups to /System/Library/Extensions

to be sure that the installer will install the driver correctly you may also want to delete the WirelessDriver receipt in /Library/Receipts (we are working on improving the installer to plan for people who do not read the readme's and to improve the readme)

Just so you know the history...

I am Yuriwho! I am NOT Rob McKeever.

Rob wrote the code for the driver (building on open source code written by Benjamin Herrenschmidt and Louis Gerbarg). Rob released the source code (not the actual driver) when he first got it working, as it wasn't up to his standards for release. I compiled the code, got it working and posted a message on the MacNN boards (giving full credit to the real authors) with a link to my version of the compiled driver. Suddenly lots of Powerbook users rejoiced now that their wireless cards worked in OS X, showing clearly that people want software that works, albeit with a few bugs, more than no software (and we wonder why M$ has 95% market share... ;-).

Since then, Rob updated his driver for 10.1 compatibility and released a package installer that didn't work correctly. As I knew he was out of town for a few days (this was the during the 10.1 release weekend) I posted a working installer on my site. He has now posted a working installer on his site too. All future releases will be posted on his site http://homepage.mac.com/robm

The source code will also be maintained at http://sourceforge.net/projects/wirelessdriver

Please realize that this is open source software, written by folks in their spare time and given away for free to benefit the community. There will be bugs and release snafu's from time to time but the benefits of this work are enormous! This effort alone has supported many mac users, Apple, Agere(Lucent), Farralon, Cabletron and several other companies. These cards will no longer be paperweights for OS X users because of these efforts.

Feel free to send Rob, Louis & Ben a case of your favorite microbrew the next time you are feeling charitable. (thankyou e-mails are nice too)

Y
 

shahn

Registered
Interesting development:

Thanks to Yuriwho for the tips and history but another little glitch:

I reformatted my hard drive to take advantage of the fact that the 8 GB installation limit for PBG3 series systems has been removed. OSX now resides on the first partition which is 14 GB. Installation of OS X.1 from the installer CD went well but it kludged the installation screen by creating a "phantom" 8 GB partition within my 14 GB. After installation was complete, there was no trace of the phantom partition and there is only 1 14GB partition with OSX.1 on it.

However, when I ran Yuriwho's 10.1 wireless driver installation .dmg file, the installer would not let me install on the OSX partition because it was not in the first 8 GB. Very interesting! There was no "phantom" 8GB image created. It sounds as though this may become a problem in the future if other installation packages won't recognize the 14 GB partition.

Any suggestions regarding:

1) Specifically for the wireless driver: I downloaded the "package_build.tgz" file from Rob McKeever's homepage but I can't seem to figure out how to load it. I can't move it into the Extensions folder because "It can't be modified".

2) In the future, is there any way to dissect an installation package and install the parts manually?

Thanks!
 

yuriwho

Registered
Very interesting, please report this to apple feedback. I suspect you have found a major bug and will need to partition your drive and install OS X on the first <8gig partition.

To manually install the driver find the file WirelessDriver.kext in the finder. Open a terminal window and type (without the >)

>cd /System/Library/Extensions

then type the following with a space at the end, do not hit return

>sudo cp -R

drag WirelessDriver.kext from the finder onto the terminal and the correct path for the file should show up in the terminal window. Now add a period at the end and hit return, the whole command should look something like this.

>sudo cp -R '/path/to/WirelessDriver.kext' .

now reboot and configure.

Y
 

Edward

Registered
I grabbed the 5G27 WirelessDriver build and ran the package installer. It did put the WirelessDriver.kext file in the appropriate directory ( /System/Library/Extensions). Unfortunately, after I rebooted I didn't see the new network adapter in my Network control panel.

The permissions look correct and I did this on a clean install of OS 10.1 on a 3 gig partition with no OS9 system folder. Machine is a PB333 using the Lucent wireless card. Also, the wireless was working in the 10.0.4 build after implementing the similar "fix".
 
Top