Wireless Problems


I have a G4 running OS Tiger. I have broadband (2MB) through the BT Broadband Basic package. [Contrary to their website these are compatible - even with the BT-105 Voyager modem!].

However, I have recently attempted to set up a wireless connection. I am using a D-Link DSL 300T Modem connected via the D-Link supplied micro-filter (I have tried a different filter just in case); a Belkin Wireless G High Speed Router (F5D7231); and a D-Link DWL-122 USB Wireless Adaptor. The Modem is set to PPPoA and G.DMT, the Router to dynamic connection.

The software support and wizards supplied are not MAC compatible so - with little technical knowledge - I had to set-up using the manual browser option (entering the assigned IP address for modem and router).

This worked the first time and I could access the internet over the wireless connection. The problem is that after a period of time, and sometimes after power-down and restart, the internet connection is lost. Everything appears to be functioning, system preferences registers a signal and network configuration registers a 'green' active connection via (en2) wireless adaptor... but all access to the network is suddenly lost and impossible to regain without factory-resetting all hardware and reinstalling software and manual settings.

I've noted that sometimes the router and OS system preferences display a WAN IP in the 86.*** range - when the internet is accessible - but appear to switch (without any obvious intervention) to the router's default IP (used to access the interface) - when the internet connection is not working. I'm wondered if the problem is related to dynamic IP settings? Any suggestions gratefully received.


It would seem to be a DHCP issue - if you have two devices both trying to assign IP addresses to other devices around them, including each other, you're going to get IP issues and no DNS resolution for browsing.

Look at the prefs of each device, and make sure only your primary router is configured to distribute IP addresses via DHCP. Then reboot everything.

James Ogilvie
Solutions Web Support