Wolfenstein demo performance

justinkim

Registered
How has this been playing for everyone? On my rather sub-par machine (G4/400 AGP 256mb RAM 10.1), I haven't been able to get playable frame rates yet. Things are ok If I'm inside the bunker and noone else's around, but the moment another player comes in sight or I look out a window, my rates drop to unplayable speeds.

I've dropped the bpp to 16 bit and all the textures to low, but still no dice. If I have to drop the resolution to 320x200 (if that's even possible), I don't think i'll bother. There's such a thing as too much compromise ;) .

It's a shame because games like Q3 and UT run perfectly well on this machine under OS9. Hopefully there's still some room for optimization to let the final product run better on my class of machine.

Anyone know how to get actual numbers forframe rates in the Wolfenstein demo?
 

themacko

Barking at the moon.
I'm not sure what my exact frame rates are .. but I agree, it's pretty weak. I'm on a G4 533 w/256 megs of ram and an ATI Rage 128 :rolleyes: and I I've got some pathetic settings going on, it's really horrible but it's the only game I've played on a mac so I guess it's not that bad.

The best thing to do is keep it at 32 bit, since the 16 bit looks like it's interlaced for some reason. Turn off dynamic lighting and turn the texture details down .. you may also want to tone down the ejecting brass. My resolution is at 640x480 which isn't good at all, but at least I can play w/o it looking like a complete slideshow. :confused:
 

justinkim

Registered
What really hurts is how well my P3450/TNT 2 machine plays the game. Very smooth, no dropped frames that can't be attributed to lag, heavy visual effects. Sigh.
 

Excalibur

Registered
I get rates around 50ish. In some parts about 90FPS with all options on. I have a dual 500 w/Radeon on 10.1. If you need to display frame rates add this line to your config file.

seta cg_drawfps "1"

That will show your frame rates while you play. Since there is no single player mode yet you can't run a demo test. Good luck and I hope that helps.

__________________________
 

godzookie

Jigglypuff Extraordinare
Hmph, feel lucky that you can actually play the game. My dual 500 refuses to get past the map loading before it (the game) crashes.


Nick
 

Ssargon

Registered
I have a G4 400 384MB RAm and a Radeon and Wolfenstein is great on my system! No dropped frames unless you count lagging from the server!

I am using the standard settings.
 

themacko

Barking at the moon.
I'm accounting my fps problems to my video card, ATI Rage 128 Pro isn't exactly "current technology." I'm betting that if I had a Radeon or GeForce 2 it would much much better.
 

Excalibur

Registered
Hey, Godzookie to play on a dual 500 it took me a while to track down the bug but it doesn't run right on a dual machine in SMP mode. You must disable the other processor to get it to work, stable. The specs I gave are running on one process, imagine if it were on two. :) Anyhow, look for this line and change it in your config file and you should be able to play it without crashing.

seta r_smp "1"

to

seta r_smp "0"

___________________________
 

Yeeeeeeha

Registered
Well, i hate one up's but I'll give you guys an idea of where top level hardware is with wolfenstein mp test.

My Mac: Dual 800/Gforce3,64/1.2Gb RAM/21" studio display/OS X

All max settings (including metal ejection, etc) at a resolution of 1024x768 i'm getting 30-50fps on the beachhead and up to 80-90fps in the buildings.

I think that is just dandy!

As far as controls and such. Have you guys tried upping you mouse speed. Mine is very zippy and baby smooth.

As a comparison, I have a single 1.5 (1800) Athlon XP/Gforce3,64/512Mb RAM/21" sony/WinXP right net to it. I get similar frame rates on it.

And a big thanks on the MP crash bug, disabling MP solved my problem too.

On a commentary note, Has anyone tried Day of Defeat? It's a HL mod on the PC. Beachhead is almost the same map as DOD's Normandy map and I think DOD is actually more engaging even though the engine is long in the tooth. It's worth checking out.:)

Also, If you have to go PC, get AMD XP.. this chip is really fast. I usually don't notice a difference in new chips.. this one I noticed.

-Y
 

Neozzz

Registered
I have a Dual 450 with 384 mb ram,
and it also crashes on the map loading screen every time!
pisses me off... grrrrrrrrrrrrrr. why can't we use dual dammit!
 
Top