x11 won't accept remote connection

hominemodi

Registered
hi. my x11 server (the one that comes with tiger install dvd) all of the sudden (seems after last update from apple) won't accept any remote connections. i have tcp port 6000 opened in the firewall, type 'xhost +' in xterm, set the display to my machine on the remote one and...'can't connect to display <ip>:0' :mad: this really sucks, as i need this functionality at work. any help would be awesome.
 

lurk

Mitä?
My first question is can you use ssh? It would 1000x better to go that route than to even think about touching anything involving xhost +.
 

spb

Registered
Check that the the /etc/ssh_config and /etc/sshd_config files allow for X11Forwarding.

I don't know about Macintosh, but in other OSs this needs to be set when the sshd is first installed.
 

hominemodi

Registered
this doesn't want to work either. in /etc/ssh_config i tell it to forward x11 then i ssh -X <host> set display, run command and immediately get rejected by my x11 :(
 

hominemodi

Registered
this doesn't want to work either. in /etc/ssh_config i tell it to forward x11 then i ssh -X (or -Y) <host> set display, run command and immediately get rejected by my x11 :(
 

spb

Registered
hominemodi said:
this doesn't want to work either. in /etc/ssh_config i tell it to forward x11 then i ssh -X <host> set display, run command and immediately get rejected by my x11 :(
Did you check the sshd_config on the server computer also?

----

You had X11 forwarding working before? What changed between when it worked and when it didn't?
 

hominemodi

Registered
it was working before. as far as i know the only change was applying the latest software update from apple. does anyone know what script actually kicks off x ? maybe 'tcp listening' is off or something like that.
 

lurk

Mitä?
X does not automatically start you need to start x11.app manually before you try to connect.
 

hominemodi

Registered
found the problem, i suck :) the display had to be set to <host>:0.0 don't know what happened 'coz i'm pretty sure i did <host>:0 before. thank you all for your input
 

hominemodi

Registered
well. the latest update from apple did change some settings and that is the very reason i was not able to accept x11 connections. the solution was to type:

defaults write com.apple.x11 nolisten_tcp false
 
Top