XForwarding in OS X

Emerrill

Registered
Basicaly I am wondering if it is possible to get Xwindows to open from a server in OS X. I am in a dorm, and so we have ver high speed internal networks, I am trying to run a program from one of our campus Solarus servers. I know they support X window forwarding, but is it possible to get it to shw in OS X, do I need to install something???.....

When I ssh -x in and try to run such a program I get

rock~% xv
xv: Can't open display

or

rock~% xreq
application-specific initialization failed: no display name and no $DISPLAY environment variable
can't read "tk_version": no such variable
while executing
"if { $tk_version < 4.0 } {
puts stderr "Xreq requires wish version 4.0 or better"
exit
}"
(file "/local/preq/bin/xreq" line 11)
rock~% tk_version
tk_version: Command not found.


Any suggestions?
 

robpatrick

Registered
I'm on a campus too and was able to ssh -X into our Linux Lab.

I downloaded and installed XFree86 in order to run XWindows. (I use WindowMaker, but twm which came with XFree86 works too).

Once I got XFree86 working (this also works in the XDarwin program, client, whatever which runs XWindows on top of Aqua so you don't have to log out) I logged into >console, started XWindows and ssh -X worked like it should out of Tom's Window Manager (twm)
.

You can start where I did: http://www.xfree86.org/4.1.0/Install.html

By the way, then I tried to ssh -X into MY XWindows session but there's a problem with Darwin when you edit /etc/sshd_config to say "X11Forwarding Yes" and then try to log in, the system logs you out immediately. Someone on this board thought it was a bug. But if YOU get this to work, I'd love to know how you did it!


-Rob
 

Zim

Registered
I had tried this under 10.0.x and given up. Yes after changing the ssh options for X forwarding, I had the same trouble, and had to ssh in using possibly the -x option (to re-disable X forwarding) and gosh something else I cannot remember... but it was a frustrating endeavor.

I can say that should your ssh connect, what I did not see stated was that you need to tell your destination machine to allow the X windows, so if you are at home, trying to log in to lab, and display an X win from lab to home, you would....

home> xhost +lab
home> ssh lab
lab> setenv DISPLAY home:0.0 (or is it 1:0 when using Xdarwin?)
lab> xterm &

should pop up at home.

This is _IF_ things worked as they are supposed to :)

Mike
 

Emerrill

Registered
I have got Xdarwin up and running. but I still cannot et Xforwarding to work. I login to the remote server using ssh (inside xwindows) and on the remoter host type

setenv DISPLAY=MyIP:0.0

I have also tried with 1.0, 0 and 1 but they all say, Cannot open display "MyIP:0.0="

Any Ideas?
 

finnboo

Registered
This might simply be a syntax problem you're experiencing. There shouldn't be a '=' sign in your setenv command. Try:

<b>setenv DISPLAY homeIP:0.0</b>

You could also avoid having to do this everytime by using the <b>-X</b> parameter when logging onto the lab machines, e.g.

<b>ssh -X labIP -l username</b>

Note that ssh is case sensitive, and the <b>-x</b> parameter disables X-forwarding.
Also, this will probably only work if you're logging in from an X-window terminal.

Cheers,
Finnbogi
 
Top