XFree 4.1

howardm4

Registered
Since I haven't seen it anywhere, XFree 4.1 is out and
the big news is that it autobuilds dynamic libraries(!!!!!).

I have a 175MB tarball of the 488MB fully compile source tree if
someone has a place to post it!

Everything built just fine, this XDarwin has the -quartz code but not rootless.

Binaries from xfree86.org are not available yet.
 

rharder

Do not read this sign.
I haven't been able to get it to install (or run, rather) properly. I get an error about missing some libs.

Has anyone had success?

-Rob
 

gabe

Registered
I got the stock XFree86 4.1 Darwin binary distribution from ftp.xfree86.org, installed it, then got the XAqua package, installed that. I don't remember where I got the rootless XDarwin app from though. But I managed to get it installed and it works great.

I'm amazed at how much better than Tenon's XTools it is even. It is VERY fast and responsive. And running rootless with XWindows popping up while I'm in Aqua is way cool. Especially with full transparency support and drop shadows (run the xeyes app for a good example of this) that XTools doesn't support even.

Now if only GNOME was ported over...
 

bioX

Registered
Which version of XAqua did you install? As far as I know only 0.5 works with the rootless patch you can find on sourceforge.net. At the moment I run Xfree86 4.0.2 rootless with the IceWM. I got the needed shared libraries just by installing the test version of Xtools. Now I do not need Xtools anymore and I totally agree that Xfree is much better and faster than Xtools. I would be very interested in that rootless XDarwin.app.

bioX
 

rharder

Do not read this sign.
Here's the notes from http://www.macgimp.org/X/. I'll try it when I get home.

=====================

MacGIMP Rootless X Instructions
1. Download http://www.macgimp.org/X/XDarwin.dmg (about 4 MB)
2. Download http://www.macgimp.org/X/XDarwinStartup (17K)
3. Get yourself into a root shell, for example: sudo tcsh
4. Open the disk image and copy the XDarwin.app into /Applications
5. Replace the old XDarwinStartup with: mv -f XDarwinStartup /usr/X11R6/bin
6. cd /usr/X11R6/bin
7. ln -s /Applications/XDarwin.app/Contents/MacOS/XDarwin XDarwinQuartz
8. get rid of the old Xfile as in: rm -f X
9. link XDarwinStartup to be the new X: ln -s XDarwinStartup X
10. chmod -R a+rx XDarwinStartup

Run rootless X with: startx -- -rootless

It is usually easier to run X from one terminal window and then run your apps from a separate terminal, so you can see any output (error messages, etc.) from X while you're working.

====================

-Rob
 

holt9106

Registered
Okay, I just followed the instructions from Macgimp.org on how to run xfree86 4.1 in rootless mode. I downloaded the XDarwin.dmg file and XDarwinStartup. After following the instructions that are outlined on the webpage and trying to start X windows with "startx -- -rootless" the XDarwin application starts up as normal in the Dock and the dialog window comes up but it soons crashes with a message in the terminal that "X connection to :0.0 broken (explicit kill or server shutdown)". Can anyone offer me any advice on this problem?

Also, I am having a problem with the Fink package manager. I downloaded fink.0.2.2 from the website and ran the install script but it tries to get dpkg1.8.3 instead of the current version that's on Debian's server. Is there a simple solution to this problem?

David Holt
davidholt@mac.com

Machine: MacOS X 10.0.4 on Revision B iMac w/ 160 MB RAM
 

bioX

Registered
Now I have updated to 4.1 and still use the quartz-mode. I also installed fink 0.2.3 and did not have any problems with dpkg...1.8.3.1 since 0.2.3 automatically grabs it from sourceforge.net (for 0.2.2 you can get it there and put it in /sw/src). Afterwards I tried to install Wmaker but always got a failure due to missing X11 paths although they where given in the configure-script. I never had these problems using 4.0.2 but reinstalled my PB for some reasons. Any ideas?

Thanks for help.
 

bioX

Registered
I found the problem on my own. I just not installed Xprog.tgz. After this installation everything worked fine including the rootless patch from MacGimp.
 
Top