XFree86 4.1.0 - XDarwin1.01a - rootless

bioX

Registered
Hi!

I just installed XDarwin1.0a1 and tried the rootless mode. Everything works fine beside one problem: I loose my mouse within pictures opened in Gimp. In full screen mode it is no problem, in rootless it is the same in wmaker or icewm. I never had this problem before with the rootless patch from macgimp.org and XFree86 4.1.0.

Any ideas?
 

tieng

Registered
would you mind sharing how you got icewm compiled under OS X? I'm having trouble getting it to work because it says it's missing 'libintl' and I'm not sure where to get it or where to put it.

Thanks,
--Gene
 

bioX

Registered
To compile IceWM you need XFree86 4.1.0 in order to have shared libraries. When installing the binaries do not forget to include Xprog.tgz. For compilation and installation of IceWM I used fink that can be found at http://fink.sourceforge.net/. Just follow the instructions given on the page and type "source /sw/bin/init.csh" (as root) prior the installation with "fink install icewm". Fink will check for dependencies and inform you about additional packages that have to be installed including e.g. libintl. With this method it should work fine in 10.0.3 or 10.0.4 (worked at least for me).

Good luck

bioX
 

howardm4

Registered
libintl is part of GNU gettext. It is for handling language internationalization.

If you dont require it (ie. you speak and want English), you may be able to tell 'configure' to not use it. It is often --disable-nls
or something like that.

 
Top