Xserve G4 Panther - Processes Max Out Cpu


I am a systems administrator overseeing a Mac/PC network (about 90% Mac). Recently one of my Xserves has started giving me problems(1.3Ghz, 1GB RAM). I have the Xserves set up on an IOgear KVM switch. When I switch to the problematic machine, I just get a black screen. Also, the row of blue LEDs on the front of the Xserve are all constantly on. KB/Mouse will not "wake" the machine. My only recourse was to perform a hard reboot. After rebooting, I enabled remote access and SSH'ed into the machine. I left "top" running and found that, after a period of time, the screensaver would kick on and immediately max out the CPU. I am able to kill the screensaver through the SSH connection and regain control of the machine. After doing some more troubleshooting, I've found that various other programs will max out the CPU just like the screensaver and I have to force quit in order to get out of them....example programs are Safari, Software Update, Activity Monitor, etc... Other programs don't seem to have a problem - Acrobat and Distiller, Terminal, System Prefs, etc... I was running OS 10.3.8 and thought updating might help. I couldn't run Software Update while I was logged in as Admin, so I tried logging out and logging in as Root and it allowed me to update....Root could also run Safari and some others. This made me think it was a problem with the Admin user, but then the Root account started acting up in the same manner. The update to OS 10.3.9 didn't help. I have also tried to fix permissions first from the hard drive, then from the original CD....it found some problems both times and corrected them, but didn't help my situation. A colleague of mine recommended trying "strace" (after researching a little, it seems as though Mac OS X has a similar program called ktrace)...I haven't had a chance to try this yet. I'm out of ideas. Any suggestions would be greatly appreciated.

Thanks in advance,

Brett Gallinger
I ended up calling Apple for support on this. They had me delete the com.apple.systempreferences.plist file from user/admin/library/preferences. I didn't realize you could delete preferences in OS X like you could in OS 9. It seemed to fix the problems I was having.

Ideally, you don't want to login through the GUI as root, unless you have a very specific need that it can only meet. Most things can be accomplished through the terminal with the su command, which will give you root like access for the duration of your session. Also, you could use sudo, the super doer, in Mac OS X, which gives you root-like access for about five minutes at a time.

Just some best practices advice! :)