Spotlight Won't Stop Indexing

Discussion in 'Mac OS X System & Mac Software' started by sgmiller, Jul 10, 2006.

  1. sgmiller

    sgmiller Registered

    Joined:
    Jul 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am a new Mac user with a brand new MacBook and Spotlight was working fine until I added a large number of files in the Documents folder in my user directory. I noticed that none of the documents were indexed so I tried a trick I read about which was to drag the HD icon to the Privacy area in the Spotlight settings and then removed it which forced a reindexing but the documents in the Document Folder were still not indexed. So, I used the:

    mdimport -f /path/to/directory

    command in Terminal to force an indexing of the Documents folder which worked and now the documents are indexed and new documents add correctly.

    However, now Spotlight is constantly indexing, either "calculating time" or giving estimates of 5-9 hours but then shortly finishing. There are a few moments where it is working normally but then it returns to the above conditions. I almost never am able to use it for searching.

    HELP!
     
  2. bobw

    bobw The Late: SuperMacMod

    Joined:
    Mar 29, 2001
    Messages:
    8,831
    Likes Received:
    5
    Trophy Points:
    0
    Occupation:
    Retired
    Location:
    Phila,PA
    1) Using the mdutil command-line utility in Terminal, turn off indexing for each of your drives. Example:
    • $ sudo mdutil -i off /Volumes/your_hard_drive_name_1
    • $ sudo mdutil -i off /Volumes/your_hard_drive_name_2
    2) Then use mdutil to remove the indexes from each drive
    • $ sudo mdutil -E /Volumes/your_hard_drive_name_1
    • $ sudo mdutil -E /Volumes/your_hard_drive_name_2
    3) Physically remove the .Spotlight directories from the root of each drive.
    • $ cd /
    • $ sudo rm -fr .Spotlight-V100
    (do the same for your second or third drive)
    Make sure to carefully type the "rm" command -- a typo could result in deletion of critical files.
    4) Use mdutil again to turn indexing back on for each drive
    • $ sudo mdutil -i on /Volumes/your_hard_drive_name_1
    • $ sudo mdutil -i on /Volumes/your_hard_drive_name_2
    5) Spotlight will now re-index all drives and should behave in a normal fashion
     
  3. sgmiller

    sgmiller Registered

    Joined:
    Jul 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the fast response. Actually, I had done some research and found the terminal commands for forcing a reindex which I did and everything is working great!

    I will archive your response in case I ever need it in the future however.
     

Share This Page