system preferences / desktop picture / stuck loading images

Discussion in 'Mac OS X System & Mac Software' started by donniecrunch, Oct 13, 2011.

  1. donniecrunch

    donniecrunch Registered

    Joined:
    Oct 13, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    mac air 10.7.2
    when i open 'system preferences / desktop and screen saver' i get the spinning beach ball and it never stops, with status: loading images. i had accidentally clicked on a folder inside iphoto containing hundreds of pictures, instead of my desktop images folder. now nothing in the window is clickable. can force quit out of it but the ball starts spinning again on re-entry as it attempts again to load images. tried restart and also safe start, ball spinning again on reentry to this syspref window. i've waited an hour. would like to terminate the attempt to load images so i can click the correct folder and be on my way. thanks for any help offered.
     
  2. Satcomer

    Satcomer In Geostationary Orbit

    Joined:
    Jul 16, 2002
    Messages:
    9,137
    Likes Received:
    9
    Trophy Points:
    38
    Occupation:
    Looking toward the sky
    Location:
    Finger Lakes Region
    In Lion follow these steps:

    1. Quit all programs then click on an empty part of the desktop until the only the 'Finder' is in the menu bar.

    2. Hold down the 'option/alt' key while click on the menu item 'Go'. Then while still holding down the option/alt key select 'Library'.

    3. When Library opens scroll to the folder for "Preferences" and open it.

    4. In Preferences find the file: com.apple.systempreferences.plist and move that file to the desktop.

    5. Launch System Preferences->Desktop & Screensaver and try again to see if it is fixed. If this doesn't fix it close System Preferences, follow the steps back to the Library->Preferences and put that file back. If it work you can just trash that file and smile.

    Good Luck.
     
    donniecrunch likes this.
  3. donniecrunch

    donniecrunch Registered

    Joined:
    Oct 13, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for your help, Satcomer. I really appreciate your time.

    I carefully ran through your checklist but the result was the same: spinning ball and 'loading images' status. I was going to replace the plist file I had put on the desktop but noted that there was now a shiny new one already in place in the folder so left it there instead. I also tried opening syspref/desktop after having put the equivalent plist lockfile on the desktop too, but again, no luck. That file was also immediately replaced upon reopening the syspref window.

    I have about 1700 photos in iphoto and it feels like the syspref desktop window wants to load them all before proceeding. This problem began when I accidentally clicked on a folder containing all of my photos from within syspref/desktop, instead of clicking on my desktop pictures folder. Is there a way to stop syspref/desktop from doing that and have it just load the 25 images in my desktop pictures folder? And why does it want to load them all even after a reboot, if that's what it's doing? I can understand it hanging first time, but not subsequently.
     
  4. Satcomer

    Satcomer In Geostationary Orbit

    Joined:
    Jul 16, 2002
    Messages:
    9,137
    Likes Received:
    9
    Trophy Points:
    38
    Occupation:
    Looking toward the sky
    Location:
    Finger Lakes Region
    Then try the same steps for the Preference file: com.apple.desktopscreensaver.rsspictures.plist . See if that helps.
     
    donniecrunch likes this.
  5. donniecrunch

    donniecrunch Registered

    Joined:
    Oct 13, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Tried that, thanks. No luck. I noticed that the small grey pinwheel beside 'loading images' in the syspref>desktop window was not even moving, so I looked in the Activity Monitor and SysPref was showing in red as unresponsive. I assume this means it hasn't been busily loading images while the beach ball spins, but rather just frozen. Forced quit out of it.
     
  6. Satcomer

    Satcomer In Geostationary Orbit

    Joined:
    Jul 16, 2002
    Messages:
    9,137
    Likes Received:
    9
    Trophy Points:
    38
    Occupation:
    Looking toward the sky
    Location:
    Finger Lakes Region
    Try signing out of System Preferences->iCloud and then signing back in. Also check to make sure you have Photo Streaming check-marked.
     
    donniecrunch likes this.
  7. donniecrunch

    donniecrunch Registered

    Joined:
    Oct 13, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the idea. But I'm not using iCloud. Haven't activated it.
    I've noted that when I open the syspref/desktop&screensaver window, the 'loading images' status is already displayed. There is no time lag at all. It's like it's locked there from before. Also, I have cursor movement control for 5-7 seconds, but it is unresponsive to any clicking. Then the cursor is replaced by the beachball.
     
  8. donniecrunch

    donniecrunch Registered

    Joined:
    Oct 13, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Found a useful thread on Apple Support that describes my problem and offers a couple of solutions:
    - moving iPhoto Library outside the picture folder;
    - another: Go to Applications > System Preferences, and then "Get Info". Unchecking "Open in 32-bit mode".
    Neither worked for me.
     
  9. Obaid M

    Obaid M Registered

    Joined:
    Sep 1, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi Guys,
    I know this is to late and no one has given the correct answer to the frozen problem. As i as well had the same problem. here is the correct steps in order that I did and it worked for me. Before i go on I have to mention that I attempted everything and send in many reports. Finally I followed the steps that were mentioned but instead i went beyond lol

    1. create a new folder on your desktop ( no need to name the folder )
    2. close everything, no windows or screens what ever you may call it
    3. On top look and make sure you have only FINDER
    4. open up GO
    5. once opened scroll down and you will notice that there are no Library file
    6. now hold down your alt button ( option ) button and you will see a library file under home
    7. open up the library file and scroll down and open up the Preferences file
    8. now grab all the files and move them to your new folder on your desktop everything must go,
    9. now re-launch system preferences and BAM it should now work
    10. go back the same steps and open the Preferences folder and you will notice some new files and that is OK, But now you have to put all those files back from your new folder from your desk top. it will ask duplicate, replace, YES to all
    11. once all files are back to the right folder, delete the folder on your desktop.

    this what I did and it worked, good luck
     
    Karen T likes this.

Share This Page