1-2 Minute Gui Freezes; 10.4; G3 Blue&white


I recently put 10.4 on my old Blue & White G3. I installed it on a brand new hard drive after removing the drive with 10.2 on it. (I still have the original small drive with 9.2)

Shortly thereafter, I started noticing that the GUI would freeze for a minute or two at a time, at about 5-15 minute intervals. The only thing on the GUI that worked was that the cursor followed the mouse movements.

Rebooting with the network disconnected didn't help. (Nor did rebooting by itself, or disconnecting the network by itself.)

Using 'top', I was able to figure out that the kernel task was using up all the CPU time during these GUI freezes.

What can I do to find out more about what the kernel task might be doing? What tools might give me more clues?
What are the specs (hard drive space, speed, amount of RAM, installed PCI cards, etc.) on that machine?

You can check the logs with the "Console" utility -- maybe look for things like a bunch of small errors occurring very frequently in one of the logs or something...
G3 350 MHZ, 448 MB memory
Internal disk interface: 6 GB Quantum Fireball (Original)
PCI Card: 2 channel ATA interface, SIIG, Inc., connected to 160 GB Maxtor (brand new)
PCI Card: 3 port firewire (Belkin, I think), connected to 160 GB firewire drive
Internal Firewire ports: not used
2 ATY Rage 128 graphics cards, 1 original, 1 bought from someone who took it out of a similar G3.

I just started Console, and added it to my login apps. If it shows anything interesting, I'll let you know.


Hmm... the first thing I would suspect are the PCI cards -- mainly, the ATA card. Can you try removing the FireWire and ATA PCI cards and booting that way? This could narrow down the problem a bit... sometimes if OS X doesn't like a certain drive controller, it'll "hang" until it times out, then continue booting normally.
Jeff, I think I don't understand something about your suggestion. Is this something to help diagnose a hang while booting? If so, that's not what my computer does. It boots normally, then intermittently hangs later while I'm working.

In any case, I might be able to run for a few hours without the firewire card, but I couldn't run without the ATA card. That's the interface to the 160 GB drive which holds all the files I work with. I wouldn't be able to actually do anything with it removed. I'm not sure how I'd use the system to see whether it hung or not.

I didn't see any hangs while working for a couple of hours today. Nor did I see any console messages. Since this problem is really intermittent, I don't know anything more than I did yesterday. I'll keep the console up and see what it shows over the next few days.


Ugh... I got your post confused with another that talked about freezes while booting -- my apologies.

I still think it would be a good idea to temporarily return the machine to an "as-stock-as-possible" configuration to see if it's something hardware related.

Also, has Spotlight finished indexing? You can tell by trying to do a search with the little Spotlight icon in the upper-right... if it lets you search, all is good... if not, the freezes could be the indexing service indexing all your files. I don't know why that would cause complete GUI freezes, but I don't know what else to suggest.
I hadn't thought about Spotlight being a possible cause. I checked it out, and it seems that the index has indeed finished. So, it's probably not that.

Thanks for the suggestions. I'll keep watch with Console and see if that gives me any clues. So far, I haven't seen a freeze while I've been working these past couple of days. But, I'm not gullible enough to believe that they just went away on their own.

I worked on this system for quite a while last night. It froze several times, and was really frustrating to use.

Console didn't show any error messages, or even any messages at all during a freeze. But, it did show one on startup from a component of the CanoScan Toolbox 4.1. The component was named something like CNxxxx ButtonManager (I've lost it and can't find the name). This was something that CanoScan put into my login items when I installed it.

Well, I've been very unimpressed with CanoScan. A previous version had a 1 MB per minute memory leak when a certain window was open. The current version tries to hog all the CPU time when not scanning and a certain window is open. I think their user interface shows very little thought or user testing. All-in-all, if I were to be suspicious of something, this is a likely candidate.

So, without any more info, I tried removing the button manager from my login items list and restarting. I worked for about two hours with no freezes. That's not conclusive evidence, since that's (barely) within the range of previous random behavior. But, it's pretty suggestive to me. If I have any more freezes in the next few days, I'll post here again. Otherwise, I'm assuming the problem is solved.