10.1 Update Issues

Does ur updated OS X 10.1 work properly?

  • Yes! It works just like its supposed to!

  • I wuz having some problems, but its working now though!

  • No, it didn't work at all, until I clean installed.

  • Whut is MacOS 10.1??? Whut is an Update? Where am I here????

Results are only viewable after voting.


Official Mac User

Before I did a clean install of MacOS X 10.1, I installed the update over my old 10.0.4. After a restart, the following things smacked into my face:

1. CD ROM support wuz broken. The 10.1 Finder wuznt even able to recognize the OS X 10.1 installer CD and asked me, whether I wanted to initialize it.

2. Apache WebSharing didn't work anymore.

3. I had a user called "unknown user" in my Login Window, but I coulnt see this user in the user control panel.

4. Most Screensavers didn't work anymore.

After I clean installed 10.1, everything worked fine again. I can now even read my old CDI MPEG movie CDs. Pretty cool :cool:

Seems like there are some bugs left in the 10.1 updater. I wanna know, what problems u had after doing an update from 10.0.x to 10.1 (UPDATE! NOT CLEAN INSTALL! CLEAN INSTALL WORKS JUST FINE!) :)
I already looked at this thread when I recognized that my Apache was broken. N I wuz also able to get it to work again.

But whut I mean is, that the 10.1 updater should have to fix this problem, and not the user who updates!
Anyways, this ain't the only bug that is 'included' into the OS X updater.... :rolleyes:
Sherlock was broken for me after the 10.1 update... so was Classic.

A) Sherlock wouldn't launch with the Cmd-F command. Clicking on it in the dock wouldn't launch it either. Neither would navigating to the file and double-clicking. I made absolutely no modifications to Sherlock at any time to warrant this. Just broken.

B) Every time I tried to start up Classic, I'd get the old "Some files need to be added..." blah blah blah... I hit ok, then it would just quit. Never could fix it, even by removing all the old extensions -- even booting Classic with "extensions off" wouldn't work. Weird.

So I re-installed 10.1 with the clean-install option (over my existing 10.1 install! Apparently 10.1 will update 10.1 also!)... weird, it didn't go through the whole formatting process, it just started installing. But, it DID clean install, as nothing was left but the 10.1 install and I had gigs of HD space I hadn't seen in ages. So I optimized with Norton with the "wipe free space" option, and everything is peachy and cool.

Problems fixed, no problemo. I highly recommend clean-installing if you can afford it.
What kind of modem problems? Were you using the "Apple Internal Modem 56k" script and it wasn't working or something?

Once I updated to 10.1, that script no longer functioned for me... the modem would just fail at every connection attempt -- no sound coming through the speaker, no connection, and, I'm assuming, no dialing... I'm using the Supra 56k script now with success, although the sound is a bit quiet coming from the speaker...
I hope the next update (10.2?) will work better. I don't wanna do a clean install everytime I install an update on MacOS X.

Btw, yesterday I read an article in MacLife about the new G5 proecessors. N it said, that Apple probably would trim OS X 10.2 to run wit 64bit n the G5. I hope they will then still give out 32bit versions for older g3 and g4 macs...otherwise everybody'd have to buy a new g5 mac :eek:

Anyways its cool. They will run wit maximum 1.8ghz!!! :) Imagine a quadruple 1.8ghz G5 Mac!!! I would sell my girlfriend for that :D j/k!!!