2002 Quicksilver has apparently died... but has it?


I have this 2002 Quicksilver. I've kept it running for all these years. It was in the basement and it's purpose was to connect to a SONY camcorder. The camcorder shot Digital 8mm film cassettes. Since upgrading to El Capitan (let alone Sierra) iMOVIE wouldn't speak to the SONY. Hence, in the basement was the 2002 Quicksilver. I actually have used it occasionally on and off for 10 years. However, on Friday I had to unplug it for some work being done and replugged it in Tuesday. It was STUPID of me not to have plugged it in in another area of the room, but I didn't. I thought it might have been the 16 year old battery and picked one up at Battery+ today. Nope. Wasn't that. 3.5v 1/2AA.

But this isn't the kicker. The monitor, you remember cinema displays? It won't come on either. No juice. Using extension cords I've plugged both in all over the basement and tried three different outlets and nothing. I plug in a lamp and it works.

Shouldn't the monitor come up anyway? Shouldn't I get power to it? Did it also have some sort of battery that could die if left unplugged?

Just not making any sense to me. The only possible explanation is that they had actually died prior to my unplugging, maybe from a surge or something, and I didn't realize it. But, I swear, this stuff has been working.

And is there anything that can be done that isn't an arm or a leg?

They really are big doorstops now. In the meantime, everything's plugged in - in remembrance of the good times ... :)


I suspect that the PMU is still crashed. Try this reset:
Unplug the power cord.
Pull and test your battery. I know you just replaced it, but a "new" battery may still be dead. Check it with a voltmeter (verify that it is between 3.3 and 3.7 volts.)
Insert your good battery (don't attach the power cord yet).
Press and release the PMU reset button on the logic board (it's near the battery!)
Do NOT press that reset button a second time, as that can crash the PMU chip.
Wait 10 seconds before you plug the power cord back in.
Try power.

Is your Cinema Display one of those with an ADC connector (which gets power from the computer?)
(An ADC connector looks like a DVI video connector, but is oval, rather than the rectangular DVI connector.
If your QS can't turn on, then the ADC connector also has no power, and the display is less than useless...


Is the PMU reset button the tiny little thing that looks like a small eraser?
If I pushed it when the battery was out can I push it again when the battery is in? (I know you suggest not pushing it twice, but I may have pushed it in when the battery was out ... as I thought that was a step I read from another thread.) In any event, it was pushed one with the battery out and everything unplugged.

The cinema display is also from 2002. It has that little box that is some sort of power supply, that plugs into the wall. there's the little wire with a plug on it that sort of looks like firewire (and then there are the firewire and the usbs that can connect to the QS along with the monitor plug). I guess the answer is "yes." it is one with an ADC connector.

There we are.

I'll await the response and give it a whirl.
Oh. I have one of those battery testers that can test 3V and 6V. Gotta love it. Of course, the 3V setting on the battery tester has the old battery reading great!!!! (And I should have had them test it at the store... which, do'h, I didn't. It was starting to do that thing where I would turn the computer on and it would be December 31, 1969 however).


PS and what is CUDA? Same thing? From another thread:

Supposedly steps from Apple (this is from 2007)

* Unplug the Unit
* Remove the Battery
* Push the CUDA (PMU) Switch (count to 5 slow)
* Push the Start button on the front of the computer (count to 5 slow)
* Let the unit sit for 15-30 minutes
* Replace the Battery
* Plug it back in, and push the start button
Last edited:


Yes, either of those steps are OK for a PMU reset (in this case, CUDA and PMU would be interchangeable terms)
The important point is, after inserting the good battery, to only press the PMU button once. If you accidentally press it again, then you can simply take the battery out, and let it set for a bit, then insert the battery, then press the reset button (once only).

If your Cinema display has firewire ports, then it is from 2004, so newer than you thought. And, the 2004 is an aluminum case, and looks similar to the iMacs of that time period. It has two USB, and two Firewire connectors on the back side.
The older, 2002 Cinema display has a clear, acrylic case (with a clear, plastic support leg in the back) and has only the two USB ports on the back. The older display does NOT have Firewire connections.

This compares ADC to DVI connectors


Yes. ADC connector. Now that you identified it... I might have hobbled a CRT with it in the beginning (which is I believe what I did ... now that I think about it ... it was $1000 at the time and that is still a lot of money ... but then it was huge). I can see it now ... weighed a ton, size of a tv set ... and I'm going to let my brain relax so I can remember the brand. Started with an "I" I think ... believe they still make monitors today :) Thanks. I'll let you know what happens when I attempt this later ...

Just remembered: ViewSonic !!! :) circa 1998 so that would make sense.


Sorry, it's been awhile because I have sort of given up. I tried your way and tried that other way numerous times. A couple times, I did the reset, then instead of waiting 15-20 minutes, I forgot about it for two days :) I guess the PMU is dead?


The PMU is simply a chip on the logic board. That wouldn't likely make everything stop working/
But, a dead power supply is the likely culprit. Pretty easy to check voltages at the power supply connector, using a voltmeter.
The relevant contacts are all listed in the troubleshooting section of Apple's service manual for Power Mac G4's.
If you don't have that, it's easy to find - http://tim.id.au/laptops/apple/powermac/powermac_g4.pdf


I'm wondering if I can achieve what I needed this computer for with Elgato video capture. The reason I needed it is the iMOVIE on High Sierra won't recognize the old 2005 Sony DCR-TRV730 with High 8 and Digi 8 tapes. I was able to hook it up with firewire to the QS, and transfer the tape to a file, then save the file and import to iMovie. Now I'm dead with this. But, Elgato has the video converter and the SONY does have an S Video connection. This may be what I need to do. It's $90. The other route is to take it to the local guys and pay $45 to hve them "look" at it then tell me what to do.