Admin password stopped working -can't log on

ohmster

Registered
Hi All,

I am newly switched back to Mac and had a problem with a "corrupted setting" in an app I tried to run this morning. I ran DiskWarrior and had to check the "ignore permissions" checkbox on the CD icon to get it to run. It fixed a handful of things on the disk, but now when I reboot it is asking me for a password for the first time. I have been successfully installing apps using this password for months, but now it won't accept the password and I can't finish booting. The hint tells me I am using the right password, but it won't let me in!

I am stuck and need to reset something! Please help!

OS 10.3.9
Dual 1.8 G5
1 gig RAM
 

bobw

The Late: SuperMacMod
Boot from the OS disk and under the Installer (or Utility) Menu, choose Reset Password.
 

Satcomer

In Geostationary Orbit
Make sure caps lock is not stuck on.
 

ohmster

Registered
Thanks. Just changed the password with the install disk and still get the shakey NO at the boot. Also checked the caps lock (nice UI reinforcement there). Also repaired permissions.

Can I just set it back to ignore permissions?
 

ohmster

Registered
OK. I was just wondering if there was some sort of a reset permisions or boot with last known good config or something. It seems a little ironic that by fixing a small file corruption problem I have locked myself out from a perfectly good functiong system and have lost a day of freelance work.

I am the admin and the only user of the system. Can I get in another way or just create another user?

I appreciate any constructive suggestions.
 

ohmster

Registered
Tried that a couple of times too.

I added a new password for root and now I have an "other" category when it boots but typing root and the new pword doesn't do anything.

Someone suggested re-installing the OS or upgrading to Tiger.

Any opinions?
 

ohmster

Registered
Well I reinstalled and even though I got an "errors" message during the install and it appeared to not complete, I got the computer back. It appears to be functioning fine.

I think I found step three...
 
Top