Airport doesn't connect to preferred network

epheterson

Registered
Airport remembers the settings for my network, if I click it in the Airport list, it'll connect right away, but for some odd reason, it won't connect automatically.

It makes me click on the network in that list, and then click connect. It has all the settings and it works right away, but it should do it automatically!

I've tried removing the network from the preferred list and adding it again but that solved nothing. Any suggestions?
 

Attachments

  • wtf.gif
    wtf.gif
    161 KB · Views: 20

epheterson

Registered
I'm on my macbook running leopard (10.5)

Overall, the wireless is better on Leopard, but I hate this little problem. Do you have any ideas?
 

eric2006

iMovie Professional
What kind of security is on the router, and does the computer know the password? Automatic connections work for me on a WPA network - shouldn't be an OS bug.

Does this happen after using another network connection, like a modem, ethernet, or a different network (all networks?).
 

epheterson

Registered
It's got a wep key, and the key is memorized. After I click on it in that list, the password is already there and I just have to click 'connect' to get on.

No other connection has a problem starting up automatically (though to be truthful, I don't use anything other than airport usually).

I think it originated when I connected to another network that has the same name, but a different wep key. It may be using the old wep key to try to connect automatically (which fails) then allow me to connect with the stored wep key, which might be saved in a different location.

It works for other wireless networks, it only fails to connect automatically on this specific one.

Btw, my name is Eric too :)
 

ElDiabloConCaca

U.S.D.A. Prime
Instead of rebuilding the keychain, simply use Keychain Access to delete all occurrences of keys that are associated with that wireless router. Also remove them from the "Preferred Networks" area in System Preferences, like in your image above.

Then, re-connect to the wireless router, entering the password and clicking the "remember" checkbox. See if that helps the settings stick. I do believe that it somehow became "confused" since you mention that you tried to connect to an access point of the same name, but different password. That could very well confuse the AirPort software and the keychain.
 

automandc

Registered
Bumping this solution since it is still valid for this problem when occurring under the latest system update (10.5.7). Not only was my computer not reconnecting to the preferred network, it was also waking from sleep several times whenever I closed the lid. I knew this was related to the airport, but could not solve the problem. I deleted preferences/preferred networks and passwords several times, but that did not fix the problem. Following the linked directions, which included the step of moving the System Preferences application (back?) to the /Applications folder (from /Applications/Utilities) fully resolved all my airport related issues.
 

morre

Registered
Thank you for the tip. When moving system preferences to the application folder it all worked like a charm again. I am though stunned about why apple does not inform about such basic thing to make the computer work....

Anyhow, thanks!

Markus
 
Top