Airport stopped working, says its working

firelingo

Registered
Hi. I have been connecting wirelessly to the same router for about 4 months now, using DHCP, and having the settings on the automatic connection. I left the computer on, but closed, so sleeping, for about two days. When i opened it, the battery did not yet run out but the internet has not connected since.

I have full connection in internet connect to my network. Status says connected. If I have the IPv4 using DHCP, the status says that i am connected but my computer have a self-assigned IP adress. When I put in the IP manually, the Network setting give me a green light on airport and says that I am connected to the network thru airport. Needless to say, no browsers (Firefox, Safari, Netscape, or Internet Explorer) have been able to connect to the internet.

I have tried running Disk Utility for any errors, but there have been no changes.

Powerbook G4
1.67 GHz PowerPC
512 DDR SDRAM
v. 10.4.11

THANK YOU!! Please help!
 

Markok765

Registered
Try Network Diagnostics.

I sometimes with Leopard get that problem. I get the first 3 in green, but ISP, Internet, and Server in red. I just go through it and it's fine.
 

Satcomer

In Geostationary Orbit
Are you running security on the wireless router? If you are turn off
Airport, open /Applications/Utilities/Keychain Access and delete any entry that has a saved password with the wireless router. Then go to Keychain Access's preferences and run Keychain First Aid.

Now go to System Preferences->Network and when Network first opens go to the fly wheel and the bottom left and use the drop down to select 'Set Service Order' and make Airport the top choice. Then in the Network left pane highlight Airport. In the right window in Airport select "Advance"/ when the drop down comes down select TCP/IP and turn IPv6 to OFF.

Turn Airport back on and re-put in the security level and password.

All this should fix it unless you really messed up things or the hardware just stop working.


One more thing, when was the last time you did some maintenance on that Mac?
 

firelingo

Registered
thanks for all your help. airport is still not connecting to the router. even when i plug in the ethernet cable, the internet is still not connecting, though Network says it is. i am currently living in poland but am going to the states in a month. seems that ill be visiting the genius bar at my local apple store.

i have not done anything with the computer except type up labs and use study resources (im a medical student), and when i could, surf the internet.

ive had the computer for about 4 years now, and its been a real gem. i hope that this can get fixed!!!

thanks again and if there is any other hope, im all ears!
 

firelingo

Registered
i restarted, i re entered my MAC address, and ive tried i think everything that i could imagine without going into airport system configurations deep in the programming of my computer. she (my powerbook) has been getting lippy with connecting to the internet for about half a year but not like this with my present router. i really cannot afford nor do i think i need a new computer, but there has to be an explanation for this.

thanks for all the replies! i wish there was a magic one that would work... :-(
 

harharpuff

Registered
My internet went on the fritz recently as well. I tried the above examples then phoned my internet/phone company. During that time my phone line was a little fuzzy so I changed channels.

When I finally talked with an agent there, all of a sudden the internet was working again, without his help. I was perplexed to say the least.

He asked if I had a 2.4 GHz phone, which I did. He said that can sometimes interfere with a wireless internet line. CRAZY. So you may want to try changing the CHANNEL on your wireless phone. My internet is back in shape now.
 

radshag

Registered
Chances are your wireless router is being used together with all the other great home appliances you have. This can cause interference and can result in you not being able to browse the internet even though you manage to get an IP from your router.

To resolve the problem you will want to check the Channel settings in the Wireless section of your router. Chances are high that you still have the default settings and the Channel currently used is 6. Change it to 1 or 11. Click apply settings (look for a button like this on the HTML page in your router) .

It is best to wire connect your computer to your router before fiddling with the wireless settings.

I hope this helps you. It worked for me

Enjoy,

Radshag
 
Top