Airport Won't Connect to Password Protected Wi-fi Networks

Inhalex

Registered
Hi there.

First off, I have to say that I am extremely computer-stupid, so any technical lingo will probably be lost on me, and also that my issue may be extremely simple to fix, but I wouldn't know how. That being said, here's my problem.

My Macbook Pro version is OSX 10.6.7, and up until a few months ago, I had no problems connecting to any wi-fi networks, password protected or not. But a while back I stopped being able to access my university's school server even with the correct password. I tried resetting my password and even contacted IT about possible setting issues, but I had everything right. I had an ethernet cord there, so I was able to access the internet anyway.

Now back at home, I can easily connect to my home wi-fi, since there is no password. But if I bring my Macbook anywhere that requires any password to access the internet, even with the correct password, it won't work. It will load as if it is going to work, but then resets and asks me for the password again.

I'm completely at a loss. I've tried searching for other posts about similar issues, but none of the steps have worked for me. Any help would be absolutely lovely.
 
Last edited:

Inhalex

Registered
According to the IT person I spoke to, I did select the correct one. I followed all of their steps to connect correctly to the server at the beginning of the year, and used it without fault for the first few months, but it seems to have just stopped letting me connect for no reason.

I also try to use the internet at a friend's house. The first few visits, I only needed the WEP key, which worked fine. But that doesn't work anymore either. Is there something else I am missing?
 

Satcomer

In Geostationary Orbit
Open /Applications/Utilities/Keychain Access and find the entries for the University Wi-Fi and delete those entries.

Then open System Preferences->Network and highlight your Airport card. Turn the Airport card off and reboot your Mac. Then after that reboot go back into System Preferences->Network, Airport card and turn it back on. Then try the University network again and see if this works.

Plus report back what frequency (a,b, g or n) and security the University Wi-Fi is using.

Good Luck.
 

Masha

Registered
Open /Applications/Utilities/Keychain Access and find the entries for the University Wi-Fi and delete those entries.

Then open System Preferences->Network and highlight your Airport card. Turn the Airport card off and reboot your Mac. Then after that reboot go back into System Preferences->Network, Airport card and turn it back on. Then try the University network again and see if this works.

Plus report back what frequency (a,b, g or n) and security the University Wi-Fi is using.

Good Luck.
Thanks for info, i tried every other way to fix the problem, even went to extreme of resetting router to factory default and reinstalling SL, lol and it was as simple as turning airport of and restarting computer.
 

Satcomer

In Geostationary Orbit
Thanks for info, i tried every other way to fix the problem, even went to extreme of resetting router to factory default and reinstalling SL, lol and it was as simple as turning airport of and restarting computer.
One other trick is something I urge every Mac user (even do it myself) is to be anal about Networking in OS X's Airport.

So if you go into System Preferences->Network pane, at the top of the the Network pane is the 'Location' drop-down. Use that 'Location' drop down and (in Lion) select 'Edit Locations'. Another drop-down list will appear. Then in the window click on the + sign to create a custom named Location. Don't worry it will act exactly like the Automatic Location.

Make a Location calling it home. Then in that Home Location re-join your home wireless network and after everything is connected correctly, click on the 'Apply' button to save this new Location. Then repeat the process when you are ready for the University wireless. This way you can keep those two Locations separate changing Locations depending where you are at. This way the settings for one network will not interfere with the other network.

You will be surprised to see this Mac user thinks the default 'Automatic' Location is not very good. Just making a new Location seems to solve a lot of wireless connection problems.
 
Top