All Icons Gone

andrewhicks

Registered
Hi,

Just opened up OSX 10.0.4 to find generic folder icons everywhere: in the Dock and in all folders. All my Apps are folders now with the application name.app.

I can't open anything or do anything with the computer. I can't open the terminal to update the prebindings or anything.

Booting with the Install CD and running Disk first Aid does not find any problems. Neither does booting into 9.1 and running Norton 6.

Total system failure. Does anyone have this experience. What can I do apart from reinstall the system and upgrades again?

Andrew
:confused:
 

kilowatt

mach-o mach-o man
Also, make sure you didn't type 'root' as your username when you were making the initial account (thats what I did).

Enable the root user in the netinfo program later.
 

molgow

Registered
i have the same problem.. but it happen just after i install OS X.
so i can't launch any applications too, and the .app folders appears too.

i would be really happy if someone could tell me what's the problem.. :)
 

andrewhicks

Registered
Hi,

I solved it following the guidlines of Apple:

Mac OS X 10.0: Generic Folders Appear in the Dock and Applications Folder Article ID:
Created:
Modified: 106241
3/27/01
5/4/01


--------------------------------------------------------------------------------
TOPIC
Under certain conditions, applications appear as generic folders in the Dock and the Applications folder.


--------------------------------------------------------------------------------
DISCUSSION
Symptom

After installing Mac OS X 10.0, applications in the top-level Applications folder and in the Dock have icons that look like plain folders instead of their regular application icons.

This symptom may appear with or without this alert message:


"Your Home folder is not available. The server where it's stored may be temporarily unavailable. . . Contact your network admin."

Products affected

Mac OS X 10.0

Solution

There are two possible solutions:

I. Disk Utility or fsck

First, try using Disk Utility or fsck to verify and repair the disk. If the issue persists, try the second solution.

For information on using Disk Utility or fsck, please see:

Article 106214: "Mac OS X 10.0: Why, When, and How to Run fsck for File System Maintenance"

II. Removing Preference files

You can resolve this issue when started up from Mac OS 9.x or Mac OS X. You must navigate to the filepath /Users/<user name>/Library/Preferences and delete three files. Follow these steps:

1. Open the Mac OS X disk in the Finder.
2. Open the Users folder.
3. Open the folder named after the affected user.
4. Open the Library folder in that user's folder.
5. Open the Preferences folder in that Library folder.
6. Drag these files to the Trash:
LSApplications
LSClaimedTypes
LSSchemes
7. If you are using Mac OS X, choose Log Out from the Apple menu.
8. Log back in as the affected user.
9. If you are working in Mac OS 9.x, restart the computer from Mac OS X and log in as the affected user.

The correct icons should now appear.


Good luck

Andrew
 

Matrix Agent

Masochist Mascot
I know this isn't the type of solution that you need, but does anyone know if there is an OS X equivalent to OS 9's "rebuild the desktop"?
 

molgow

Registered
Hi Andrew,

Thank you for your reply, but I tried to do what you said, and it doesn't work.

First, i looked in my "Users/" folder, but there's only one folder (an empty folder) named "Shared". I thought it was because i was on OS X, and then i rebooted on OS 9.2.1 and saw that there was no invisible files in it.

Then, I tried to look for "LSApplications" (and the two others..), and i saw there was a "LSApplications" file in the "private/var/root/Library/Preferences/" folder. So I deleted the 3 files, and rebooted on OS X. And it still didn't work :-(

And I can't use the first solution, because i can't launch applications on OS X, so I can't launch "Disk Utility"...

I would really appreciate if someone could tell me a solution that works ;-)

Thabor
 

Matrix Agent

Masochist Mascot
If you boot up with you Mac OS X install CD you can use the menu bar to access the disk utility stored on the disk.
 

kilowatt

mach-o mach-o man
Originally posted by molgow

Then, I tried to look for "LSApplications" (and the two others..), and i saw there was a "LSApplications" file in the "private/var/root/Library/Preferences/" folder. So I deleted the 3 files, and rebooted on OS X. And it still didn't work :-(

not to be repetitive, but if you created the user 'root' when you installed Mac OS X (as apposed to creating another user, say named 'molgow' and then using netinfo to enable root), then thats the prob.

At least it happened to me ;-)
 

molgow

Registered
When i installed OS X, i created the user "molgow" and it didn't work.
But now i tried to log in with the root user and it works, so i can use OS X now but only with the root account. This is really strange.. i'll try to create a new user to see if there's problems or not.
 
Top