AppleTV 3rd Gen - Won't connect wirelessly to iTunes and films/TV shows stuttering

bowjest

Registered
I've had an on-going problem with my AppleTV(s) for over a year.

The first one I bought just coughed and died about one year after I got it and all I was told was that I could buy a new one for £49.00 instead of the full price.

I got the new one and it was fine until about a week before it was one year old and suddenly it would just suddenly say that home sharing was not turned on or that iTunes was not on on my computer and so we could watch nothing. I'd leave it alone for few hours and voila, it would work again.

On the day that I had had this second ATV for one year, I took it to my local Apple store for advice and without me saying any more than I've outlined above they gave me a new one - free of charge. Hmmm. Very nice, but sounded to me like there was a possible known issue.

That worked fine for about a week and then the same old "home sharing not on thing started again" - and never recovered. I've rebooted, updated software (both for the ATV and on my MBP - now running Mavericks with iTunes 11.2.1), but nothing will get the two to connect wirelessly. I can see YouTube, Vimeo, etc on the ATV box and have no issues using my network from my MBP. I'm typing this now with no problems, using email, etc.

Anyway, I gave up trying to use a wireless connection and connected the two using a standard ethernet cable. Fine, at least that works.

But now, as of about 3-4 days ago, unless the program I'm watching is physically located on my MBP (I have a Western Digital 1TB USB drive that holds all my videos plugged into my MBP), playback begins to stutter within about 10 minutes of starting a show. This has NEVER been a problem before and I have been plugging in the external USB and watching ATV via ethernet to my MBP for about 6 months or more.

I've checked iTunes so see if I can increase the buffer size or something along those lines, but no such setting seems to exist in 11.2.1.

This has become really frustrating and I'd throw the thing out of the window if I didn't need it to watch all my favourite shows.

Has anyone got any suggestions on how I can get at least smooth playback using my USB > MBP > ethernet to ATV setup again?

OSX 10.9.2
2.2 GHz Inter Core i7
16GB RAM

iTunes 11.2.1

ATV 3rd Gen

Thanks,

Bowjest
 

bowjest

Registered
Plusnet Technicolor TG582n

But just to confirm: everything worked fine when I set it up. I have made no changes of any kind to the router setup. I have a powerline extender set up in the house due to thick stone walls, but again, this was set up from the start and I had no problems getting ATV and MBP to work together for a couple of months before this problem suddenly materialised.

I can watch Vimeo, YouTube, etc. from the ATV. I can watch same from MBP, send mails, Skype, etc. and both ATV and MBP are in the same room using the same powerline connector (Maplin branded device - not sure of the particulars).

Both ATV and MBP display that they are connected to the same router (Plusnet as above), but on the ATV under Settings > Computers it says all computers with Home Sharing will be listed here. There's nothing (iTunes is on, Home Sharing is enabled. I've turned Home Sharing off and back on over 20 times or more on both devices, logged out of my iTunes account and back in over 20 times or more, etc.), but ATV still refused to see the MBP.

The ethernet cable was a perfect solution. I could instantly watch shows again, but as of about 4 days ago programs that aren't directly on the MBP start to stutter. If I just let this go, within less than 10 minutes the sound goes (picture remains moving). If I then try to back out of the selected show by pressing the Menu button on the ATV remote the picture goes black and nothing happens for several seconds before I get my list of programs back. I go back into the program and all is fine - for the next few minutes.

If I back out of the program as soon as the stutterting starts and then immediately go back in, all is fine - until it starts all over again a few minutes later.

Feels like some sort of buffering issue, but I can't find any settings anywhere to allow me to increase the buffer any.

Bowjest
 

bowjest

Registered
I think this might be your problem. That device has a built-in firewall and it might be the problem. With a third party router check the ports listed in the Apple document Well known TCP and UDP ports used by Apple software products.
Thanks, Satcomer.

That sounds reasonable, but I have to say that it worked fine out of the box for several months before it just refused to connect any more.

I've submitted a ticket to my ISP for advice on how to configure things as the process isn't as straightforward as it was on my previous Netgear router.

Hopefully they'll have the answer.

Bowjest
 

bowjest

Registered
My ISP has replied that they have no special restrictions (read no restrictions at all) in place that would prevent me from using AppleTV on my home network.

Indeed, they went on to reference the fact that I had it working initially as proof that they don't restrict this in any way.

Has anyone got any ideas? This has really become super tedious. :(

Many thanks for everyone's input.

Bowjest
 

twister

Howdy
I've got a similar issue. Seems to have come up since I installed 10.10. For now, I run a networking cable from the computer to AppleTV. Sucks, but I can't deal with the jumpy TV.
 

bowjest

Registered
I've had some progress of a sort on this.

A few days ago my powerline extender died and I had to buy a new kit (Maplin Av500). I cloned the settings from the router to the extender and had my network back up and running again. Great.

I then decided to check my iTunes wireless sharing from my MBP to my AppleTV. Miraculously, this started working again as did wireless drag and drop of videos via browser to VLC for iOS. Great again.

But yesterday while watching a video on AppleTV it just dropped suddenly. So I restarted iTunes and all was fine for a few minutes until it all dropped again. This time I had to reboot my MBP to get the wireless connectivity back. Then, again, after a few minutes it died once more and now I can only connect my MBP/iTunes to my AppleTV unit via a CAT5 cable.

So I'm right back where I started.

If anyone understands what's going on here, I'd appreciate hearing more.

And just to confirm: I have NO PROBLEMS with internet connectivity for any of my devices themselves, I just can't get VLC for iOS or AppleTV to connect wirelessly to my MBP.

I have NOT changed any settings since setting up the new powerline extender (which enabled everything to work as expected for about 3 days) and I have not installed any new apps or altered anything on my router. It all just went from working to not working.
 
Top