Big Giant Warning With 10.1!!!!!


wandering shadow
Just when I thought things were great with the update...

I just found out that 10.1 totally messed up many of the Unix commands during it's installation. It seems that it started to write the files, then just skipped to the next one. This left me with many commands that don't work. They seem to, you can write them into the terminal, but they don't give any messages back. My big clue was when I coudln't use gunzip to un-gzip a file.

These commands are just blank files on my system! I'll list them here, but they could be different for you guys:

in /usr/bin:
arch, at, atq, atrm, batch, c2ph, chfn, chgrp, chpass, chsh, cksum, compress, cpio, emacs, emacs-20.7, ex, flex, groups, gunzip, gzcat, gzip, hexdump, id, lex, machine, od, perl, perl5.6.0, pstruct, reset, sum, tset, uncompress, uptime, vi, view, w, whoami, zcat, zcmp, zdif

in /usr/sbin:

I don't know what happened. I had no errors reported to me whatsoever during the 10.1 install. I want to note that I bought the retail version, and I also installed the Dev Tools. I don't know if the Dev Tools did this or not. I'm in the process of fixing these things.

Other than trying out each and every command, you can check to see if you have this problem by typing this command into the terminal:

l /usr/bin/ | grep unknown | awk '{print $9}'

The messed up files got saved under the group unknown, and none of the others did, so for me this showed me which files this happened to. You may also want to check out /bin, /sbin, and /usr/sbin.

Hopefully, this is something that only happened to me, but I thought I'd warn others of it just in case!

If it did happen to you, you can restore them using the terminal, but it's a long & slow process. You'll need to type the following command as root (or sudo) for each of the missing commands (you'll need to have the 10.1 Install/Update CD in):

gunzip -c /Volumes/Mac\ OS\ X\ Install\ CD/System/Installer/Packages/*PACKAGE_NAME*.pax.gz | pax -r -s ',./usr/bin,/usr/bin/,' './usr/bin/*COMMAND_NAME*'

I had to download gzip (which includes gunzip) from before I could even try to fix these things. Good thing make wasn't one of the broken files! :p seems that my missing programs were in more than one package. I started with the Essentials.pax. It also seems that not every command from the pax file will get installed - some of them stay as empty files even after the re-install. I'm going to have to dig up my old 10.0 Install CD and hope that none of the commands were updated that much....

What a pain!
I haven't checked your complete list, but my vi, chown, uptime, gunzip, and whoami are all working fine, and I have no blank files in /usr/bin.
Good! I hope it doesn't happen to anyone else. It's a real big pain in the ***

I figured out why pax wouldn't write some of the files back out - those ones happened to by hard links. <sigh> But my system won't delete them - not even as root. Heh, it tells me the file doesn't exist, but if I try to overwrite it, it tells me that the file exists. Wish it would make up its mind :p

I'm gonna have to boot into 9 and see if I can figure out how to delete the files from there.

Oh, just to mention - I installed the 10.1 over 10.0.4. Couldn't afford to erase the disk and start new, I don't have enough CDs to burn all the stuff I've accumulated so far. :D (plus I have a SCSI CD burner, which doesn't help me out any in OS X)
Nah, gonna do them by hand. If pax couldn't overwrite the old hard links that were already there for me as root, it probably won't work trying pax from the install CD (that's what it uses...).

I'll probably do it tonight after I wake up...just got home from work and I'm beat, heading of to bed soon.
did you click on "install BSD subsystem" in the installation. I know it was an optional install, and it exists on the update cd as a separate install as well, so you may be able to restore all your unix progs/commands with a few clicks rather than a few hours.
heh, course I did. And, a lot of these messed up commands are in the Essentials package, which gets installed by default even if I had forgotten to check it.
Same thing happened to me. I went to check my uptime (because I haven't need OS 9 now that I have Unreal for OS X), and nothing. That seems like quite a bug (specially for terminal jockies who are looking at their first Mac OS).

Time to look for a solution to this. Still, it is very strange.
Hmm...are the same commands I listed the ones that are messed up for you? If they are, I could write a shell script to fix them in case somebody else stumbles over this as well.

If you want gzip and gunzip back so you can try my above commands, i can upload the two. Let me know.

You'll also have to delete some files in OS 9 to fix it, because OS X *won't* allow you to delete them, even as root.

I haven't actually gone through fixing everything, I'll be doing it tomorrow or Saturday, and I'll give a full report then.
I opened up the 10.1 CD, found the BSD.pkg and double clicked on it, and let the installer do the rest. It looks like I have all my commands back in the terminal. An ls of /usr/bin shows a full list of the things that I was missing and all the things I thought should be there (including the ones you listed). And the ones I tried seem to be working okay.

Still, it is not something that I would have thought Apple would over look on such an important release. I would bet it has something to do with the problem they have been having with pax. Fortunately I didn't have any symbolic links to damage (I saw that happen in Mac OS X Server quite often).

Hope it works out as good for you. As of now, my systems seems to be running fine (knock-on-wood).
RacerX - I found out what the problem was, and it was a doozy.

I went and fixed all of my commands. Was very happey...then *poof* they all got messed up again. The same exact ones.

So I decided to reinstall from the CD like you did. Ran fsck before I did it - always do that one - and, like has been happening recently, got a lot of indirect inodes that it had to fix. Well, did that, then booted off the install CD. Installed everything fine.

Rebooted into single user mode after it was done and ran fsck again - bam! Had one enourmous disk error! fsck couldn't fix it. Booted into 9 and used Disk Doctor - boy did I have a lot of problems with my drive!!

Rebooted after that into single user mode again...ran fsck again...fixed some minor errors (I swear, anytime I run Disk Doctor, it fixes some and leaves others...).

Now I'm back up...the commands are all fine, and hopefully will stay like that!

I'd suggest you take a look at your drive, just in case!