Big problems updating 10.2 to 10.2.3!



I have been trying to install the update from 10.2 to 10.2.3 on a friends 3 month old Power Mac G4 (dual 1Ghz) and I have run into a serious problem;

I open up the install package and click okay on all the agreements and info screens, but when it gets to the screen that lest me choose the disk to install to, it will no let me select any disk. They are all considered non upgradeable and it seams NOTHING will get it to work (and I really mean this). I have tried both installing 10.2 again on the same disk and on another disk (clean install) and it just dont work. This is only from the .dmg image that you download from Apples website as he hasn´t got any broadband internet uplink at his house. I have even tried hacking the .pkg file so that it allowed the install, but that rendered the OS nonusable by making it freeze on startup.

Please give me any suggestions you might have or any real info from situations like these that you have run into!
Thanks for your reply!

I cant check this right now but the same problem appeared when I tried to install the 10.2.2 update. So I dont think thats the problem.

The installer I used was the 60 MB one (if you know it by size).

I will however check it out as soon as I get access to the computer again.
You're sure you've got the combo update? The file name should be MacOSXUpdateCombo10.2.3.dmg :)