Black screen on startup / recovery not accessible

Duncanc

Registered
My spec: Mac Pro 5.1 2010, 6-core 3.33.

Hi, I’m hoping you can help - my computer knowledge is basic, but think my Radeon Sapphire 580 Pulse GPU might’ve died!

I had the 580 running ok for a couple weeks. I’d updated from High Sierra to Mojave 10.4.6 on a boot camp partitioned make sure it worked with my essential software (Avid Media Composer v.8.4.5) and it all worked fine.

So yesterday I updated my mac’s man in SSD HD to Mojave (and erased that bootcamp partition intending to make it a High Sierra partition in case I need that, but haven’t done that yet).

that worked, so I then put in 2 new PCIe cards:

A sonnet fusion dual which will allow me to put 2 SSDs on it and RAID 0 them (haven't got the SSDs yet, so it’s just the empty card I put in).

And also another sonnet card with 4x USB-C ports.

The 580 is quite big, so this left things pretty crammed inside the Mac’s PCIe space. I had put the card in the second slot up from the bottom so it had plenty of space around it, but now moved it to the bottom slot so I could fit the sonnet cards in: The Fusion Dual card in the second slot up and the USB-C card in the fourth slot up (top slot).

Stared my Mac ok and checked the hardware and it could see all 3 cards, all 3 stating 5Gb speed.

Black screen on startup / recovery not accessible

Finally I installed the Avid Media Composer video editing software. When install completed it asked me to restart, so I did and the 2 screens stayed black (Apple LED Display and an Acer display).

Tried unplugging and swapping display inputs and tried cmd c for recovery. Nothing, just black.

I took out the two sonnet cards and tried the 580 in a different PCIe slot. Still black screens.

Took out the 580 and put the original GPU in (ATI Radeon 5870 HD). Restarted and now the display lights up! I get the Apple logo and the loading bar below it. The bar take a very long time to load and while this is happening the 5870 fan is getting louder and louder. The bar finally reaches the end but nothing happens. After 15 minutes of the 5870 fan going crazy I turn off - the GPU is burning hot.

I assumed the Avid Software install had corrupted something so I plugged in my time machine external disk which revert to High Sierra (unfortunately that was the last time I backed up). Tried recovery mode with cmd c, but it doesn’t work - just repeats the logo/loading bar thing again.

Note: Its an windows (Avid) keyboard so I’ve remapped cmd to it’s control key, but I’ve restarted again and again using every one of those keys with ‘R’ and none are giving me recovery mode.

However if I hold option (Alt) I get the choose startup disk screen. But that doesn’t show the time machine external drive, only the SSD HD taking me back to the logo/loading bar forever.

I’m guessing the Mac is can’t start with the ATI Radeon 5870 HD because it’s not ’metal’ and the OS is Mojave, so it’s incompatible and that’s why the GPU just spins, getting hotter and hotter with completing startup!!!

so I’m stuck! black screen with the 580. The 5870 won’t start because it’s not metal and recovery mode isn’t working. No idea what to do!

I wonder if it’s either a corruption, or virus for the Avid software, or if something in the 580 has fried!

if you can help you’ll be a life saver - I need my Mac to work, so I’m in a bad place now!
 

Duncanc

Registered
Looks like my Sapphire 580 Pulse GPU has fried in my Mac Pro 5.1 2010.

It was running fine on Mojave 10.14.6. Then I put in these two Sonnet cards:

Allegro USB-C 4-Port PCIe Card

Fusion Dual 2.5-inch SSD RAID card

Note: the Fusion Dual card is designed to have 2 SSDs on it, which it can either RAID 0, RAID 1, or JBOD. I don’t have the SSDs yet - they come today - so I put it in empty to see checked it fitted (its quite long) and showed up. I hope putting it in empty isn‘t a ‘no-no’!

I started the Mac and all seemed fine. Checked the hardware and all 3 cards showed up with speeds of 5Gbs.

i installed Avid Media Composer software which needed a restart and this time the neither of my 2 displays came on - black screens! I can hear the hard drives working away, but no displays. I’ve since swapped the Sapphire 580 for the original GPU, an ATI Radeon 5870 HD and got to recovery mode (I believe the Mac won’t start because Mojave doesn’t work with the NON-metal Radeon 5870).

I’m now restoring High Sierra to my SSD HD, but I suspect that the Sapphire 580 will still be ‘black screen’, meaning it’s fried. I’d previously tested Mojave with the 580 running the Avid software on a bootcamp partition and all was good. The only thing that changed this time round was the addition of the 2 sonnet cards (and I did a Mojave Security Update!).

So my question is one, or both of these cards have blown the 580 GPU? Could the combination of these 3 cards have blown the 580 GPU?

Any theories are gratefully received, since I’ll have to get another GPU of some kind and don’t want to blow that one up too!

Cheers
 

Satcomer

In Geostationary Orbit
Sometimes static cling can mess with things especially in older homes. Try these steps:

1. Unplug the display cord and plug it back in!
2. If step one doesn’t help then Reset NVRAM or PRAM on your Mac doing twice before letting to boot back up! This will reset you ports in your Mac!
 
Top