boot camp & startup disk stopped working - EFI/Firmware problem?

#1
I am running Snow Leopard on a 2.4GHz MacBook Pro, late 08 - early 09 model. I have been using boot camp to run Vista for the past year with no problem. This morning, I tried to start up Vista and it wasn't working. I got the option key screen to choose between OSX and Vista, but after choosing vista, the cursor blinks once and I get a black screen. The computer is quiet and nothing seems to be running.

At first I thought it was a boot camp problem. So I went into OSX, de-partitioned the drive, and repartitioned it. I then stuck the Vista install disk in, and clicked through the boot camp assistant to reinstall. The computer restarted to begin the reinstall process, but instead of starting the install disk, it did the same thing - a single blip of cursor, and then a black screen.


I'm not technically savvy, but that seems like it's not a Windows problem, but a firmware or EFI problem. The computer will run OSX, but it won't run boot camp and it won't start from a CD-ROM. The only other steps I've taken are to run Software Update and the Disk Utility from Safari. Neither helped. I'm out of warranty and would love to be able to fix it without spending tons of money. Any help is appreciated.
 
#3
I couldn't find the original Leopard disk, but the Snow Leopard update disk seems to load fine by holding 'option' on startup and selecting it - though it did take about 6-7 minutes to load.
 
#4
A few updates:

I tried resetting the PRAM and SMC, neither of which worked.

I ran the EFI update utility, which says the EFI is up to date.

The only thing I installed recently was Civilization V for Windows, about a week ago. I can't remember if I had switched to OSX and back since the install without having a problem, or if I just left it on Vista straight through the last week.
 
#5
I have EXACTLY the same problem. I started Win 7 this morning from and as soon as I started it the screen went black. I tried everything that you tried. The windows installer will not see the installation disk. I get 2 blips in the top left of the screen and then nothing. Re-Did windows partition and still the same. It is a Mac issue for sure. I have the latest updates for my Mac system. Running 10.6.5.
 
#6
well i have the exact same problem (happened after installing lion)
yet i have a little feedback witch might help.

i have wvfusion on witch i could log into w7 ultimate w/o any problem
that way i could recover files.

this probably means that something is missing on boot files I'm not a dev
but some1 could check on booting files so we could fix this.

atm I'm going to repair disk from lion recovery partition if this docent work
I'm going to try to repair disk with installation disk snow leopard, and yet if that docent work going to format all again and install snow and go straight to bootcamp (w/o) any updates to see if this is a problem of bootcamp 4.0 or 3.1
 
#7
this is a post i found and OMG IT WORK at the botom u can see the macbook aplication.

(POST)
OK I feel like an idiot and would be really upset, if I wasn't extremely relieved!!

THIS WORKS!!

I had the SAME ISSUE as posted above (Could not get the Windows 7 installer to start in Bootcamp... it just hung on the black screen with the cursor blinking in the top left corner)

I tried everything!! Verifying and Repairing the Partitions... from the OS AND THE INSTALL DISC! (Neither works, by the way)

The ONLY thing that works is unplugging everything, including power for 20 seconds, and then leaving ONLY the mouse and keyboard plugged in.... then restart, holding the ALT key to choose to boot to the Windows disc. It's almost like magic (Cause nothing scientific worked... TRUST ME!!)

Now, to give people another riddle to solve.... I HAD WINDOWS 7 installed on this EXAAAACT iMac BEFORE!!! I had to reinstall Snow Leopard yesterday.... and got this issue the SECOND time I installed Windows 7!! (It did NOT give me this headache he first time I installed it!! It simply installed normally!)

There is apparently some strange glitch at work here... but, like I said... NOT WORRIED, cause it WORKS now!!

Anyone having issues, just skip the other suggestions and just unplug everything... it DOES work.
(POST END)

in case of macbooks when getting to black screen press power bottom for 20 sec then press it again to start macbook but keep pressing for 10-15 sec till prosessing light (litle white line on the right front side) start to pulse fast then release and done.

PLS SPREAD THIS TO ALL THE PPL U CAN SO PPL CAN FIX THEYR MACS

and if u wana know what was the problem its this:

"electric overcharge" and u discharge it by doing that.

THIS IS THE POST LINK
http://social.technet.microsoft.com.../thread/49be37ac-c20f-4fdc-a28c-eeacbae74028/

IS 1 OF THE LAST POSTS
 
Top