Boot camp wont get to windows install


When i tell bootcamp to start windows installation, it shuts down mac os like it should, but then when it comes back up i just get a blinking line in the top left of the screen and never get to the windows install screen, i have tried it several times and all i get is that blank screen even after leaving it up for an hour plus to see if it would finally prompt me to install windows, but never did?

any idea why this is happening or what i can do, and im using a copy of xp with sp3 so it should be good there.
I have the file downloaded to upgrade to 2.1, but since it is an exe windows file how would i have it run to make bootcamp even get me to the windows install screens, since i still have yet to get to one of those. Since i do not have a previous version of xp installed, just have the disc for sp3
It will, and I also have tried a xp sp2 cd straight from microsoft, and that was used to install windows in vmware, and has been used to install windows on a pc, and both had the same issue when it came to boot camp.
I'm having almost exactly the same problem, though I'm using an XP disc from a friend... It sucks, nothing seems to work.