Can't Boot Up, Disk Utility And Fsck Report Hd Ok


Hi all,

this is my first post. thank you in advance!

my mid-2009 MBP running Mavericks won't boot up past the grey screen and load wheel. this happened after i had to force shut-down with the power key b/c the computer had frozen. i rarely do this, but the handful of times i've done this in the past, the MBP rebooted fine.

here are the things i've tried:
1. booting in safe mode -- will NOT boot into safe mode
2. disk utility - repair disk reports HD is OK
3. repair permissions -- many permissions couldn't be repaired, but it completed
4. fsck -- also reports HD appears to be OK
5. resetting NVRAM/PRM -- didn't help

FYI - my optical drive does not work. so i can't boot from DVD (which i can't find anyway, bummer!)
i have no TimeMachine backups, but my important data is backed up weekly on CrashPlan

any thoughts on next steps??? thanks!
There's always a risk to the system software when you have to force a shutdown. You may be lucky, with no effects - or you succeed in corrupting a few critical files (and your Mac won't boot again)
You SHOULD normally just restore from your Time Machine backup, and this would make your return to normal much faster - but you don't have that backup.
So, moving along:
Boot to your Recovery system (Command-R), and reinstall OS X. You won't lose anything, and reinstalling should return you to your most recent setup.
note - sometimes , system freezing is a symptom that the hard drive is beginning to fail. If the hard drive is as old as your MBPro (and came with it), 5 years is a good life for a hard drive, and you might consider just replacing that hard drive with new.
hi deltamac, thanks for your reply. i attempted all of the above, but unfortunately it gives me an error when trying to reinstall os x "an error occurred while preparing the installation". i tried the fix of opening the command prompt to check if the date and time were correct, and *unfortunately* it was. so that was not a valid fix for me. i also found my boot disk, and that installation won't work either (yellow triangle on my main drive). it seems that no matter what i do, i can't unmount my main drive, so i think that's the problem.

i tried unmounted from command prompt, even using the "force" command, but it still says that it can't unmount.

fyi, i have a SSD, 500MB - which i'm assuming shouldn't be subject to the same deterioration as a "normal" hard drive with RPMs, but i could be wrong.
You may need to erase and reinstall. If you are OK with that, you can boot to your installer DVD.
Go to the Utilities menu, choose Disk Utility, and erase your hard drive.
Quit Disk Utility, and continue with the reinstall. If that is the original Leopard system, then you will need to update again to Snow Leopard, so you can update THAT system, and you can then download Mavericks through the App Store. If you have created a bootable USB installer for Mavericks (which is fairly easy to do), then that will get you working again, with much less time involved.
unfortunately, no matter what i do it always gives me the error of "could not unmount disk"... i have tried erasing through disk utility and through command prompt. i fear my computer is a brick, or i have to take it to the shop. any other suggestions? thanks so much for your help so far.
Disk Utility - select the disk (the line with the model name/number), then the Partitions tab.
Choose "1 Partition" from the Partition Layout drop-down.
Name the partition, if you like, then click the Apply button. That will do a quick clear out of the partition setup, and should give you a free partition that you can now reinstall OS X.
Before doing an OS X install, and after preparing the partition, I will usually shut down, so the computer is OFF - and then boot back up to the installer, then you should be able to install successfully - or, perhaps the drive is simply failing, or a common fault in MBPros is the SATA drive cable.
No, SSDs don't fail in the same way as a spinning hard drive, but can fail in ways that spinning drives do not - and still a possible failure for you.
I'm pretty sure it's hosed :(:mad:.

I have tried partitioning through disk utility and through command prompt...each time getting some new error for me to search Google for. The most recent error is an input output error. I actually managed to erase the drive through command prompt, but that's where partitioning failed yet again. All my searches on that seem to show no recourse. I think I need a new ssd and maybe upgrade ram while I'm at it. Thanks for your help. My ssd has let me down :(