can't delete a locked file

Status
Not open for further replies.

mbenchoff

Registered
After I installed OS X I decided to go through my other partitions & do a little spring cleaning. In all, I trashed over 400MB of crap, but one file has refused to be deleted (it's a locked file left over from the old 3Com ISDN modem I had). When I try to empty the trash I get the following message:

"The operation cannot be completed because the item 'IQ320.BIN' is locked."

So, I look through the system help & find out that I either need to log in to OS X as the user who created the document ('root') or restart into OS 9 & unlock it from there.

Well, neither tactic has worked thus far. I restarted into OS 9 but found out that I can't access the file because it's in the trash (in OS X), which is an invisible directory (/Langly/.Trashes/102/). So then I restarted into OS X, logged in as root, but I still couldn't delete it. Desperate, I opened terminal, switched to root (su) found the files, but still can't delete the darned file. I tried rm, mv (thought if I moved it to somewhere that OS 9 could see it...), even chown, but each time I got "Operation not permitted." Any thoughts out there? Thanks.
 

The DJ

Registered
Same experience here. This is the only way i found to delete the file.

Go back to OS9.
Use the utility Filebuddy. Choose "Get info" from the "File" menu. Go to the drive partition from which you wanted to delete the file/folder. now open .Trashes and then 102. Now you should see the file/folder you wanted to trash. Select the file and click "Choose" . You now get a large window with all kinds of info on the file c.q. folder.
Click the dustbin (trash) icon in the upper right corner of the window. Choose "Empty the Trash" in OS9.

You can get FileBuddy here.
http://www.skytag.com/filebuddy/
It is an indespensible tool

DJ
 

DeltaMac

Tech
Wow - talk about dumpster-diving, eh?
Did you also notice this thread (as most threads on this site) is about Macs running OS X (also OS 9 in this case)?
Reviving a 10-year(!) old dead thread - and with a Windows-only solution, too?
Must be a new record on this site... :D
 
Status
Not open for further replies.
Top